[Solved] BPI-M2+ red LED won't boot

My BPI just shipped in!

I ordered a 5v/2a power cable…it was DOA but I found a replacement in my home (PSP slim cable is 5v/2a).

I bought a Verbatim 8GB SDHC Class 10 micro sd card and burned the Debian Jessie Mate image from 2016-05-16. The MD5 is: ea6660f5d3284c61e8950af6704bb76e

I had to use diskpart and dd for windows to write the image because win32diskimager would not load maybe because I was using an SD adapter??? The steps I took were:

  1. diskpart
  2. select Disk 1
  3. list partition
  4. select partition 0
  5. delete partition 0
  6. select partition 1
  7. delete partition 0
  8. dd bs=1M if=c:\banana.img od=d:
  9. verified write was successful

When I plug in my board the red LED comes on but it will not boot. The HDMI shows no display. Any ideas?

please check this documents:


I’ve virtually followed all of the steps listed in the document.

I was able to get win32diskimager working and wrote 2016-07-12-raspbian-lite-bpi-m2p.img to it after formatting. Still get a red LED with no display via HDMI.

HI: Please follow the following steps.

Step 1: Check your SD-Card path , Please run this command > sudo fdisk -l

Disk /dev/sdb: 7969 MB, 7969177600 bytes
246 heads, 62 sectors/track, 1020 cylinders, total 15564800 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0008c7e4

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1          204800      307199       51200    b  W95 FAT32
/dev/sdb2          307200    15564799     7628800   83  Linux

Note: My sd-card path is /dev/sdb

Step 2: Put the image to SD Card with DD command.

sudo dd if=2016-06-14-busybox-1.24.2-preview-bpi-m3.img of=/dev/sdb bs=10MB

I was able to get my pi running earlier this week. I put in a non-brand sd card and it booted up instantly. All is working well now. Will post a review soon!

I think it is the problem with your image burnt into the SD Card, try burning it in Linux environment as it would be more reliable.


Hi there,

I’m completely new to the Pi topic. Nevertheless I got into it through reading Internet articles. I received my 4 Banana Pi M2 + 1 day ago. Now I am trying to get this thing running.

  • Plugged in HDMI
  • Plugged in power supply (5v, 2,5A)

Installed 2 branded SD cards (Class 10) (Samsung and SanDisk) with Ubuntu mate 16.04 Image as the instructions say here: http://wiki.lemaker.org/BananaPro/Pi:SD_card_installation

However the Banana Pi won’t boot. The LED continiously shows a red light and nothing happens when i push the power Button.

Help would be highly appreciated!

Just follow Armbian’s instructions step by step: https://docs.armbian.com/User-Guide_Getting-Started/#how-to-check-download-authenticity

And I would recommend to also start here instead: https://www.armbian.com/banana-pi-m2-plus/

Hi There,

got it running. The LED won’t change to green or whatever during bootsequence. It just stays red but the Ubuntu Mate 16.04 from the banana Pi website booted up anyway.

I just was too focused on a green or changing LED on the Banana Pi instead of looking at the boot sequence i guess. Sorry for the newbish question.

Thanks a lot for the help.

I am having the same problem, it was working fine before. Were you able to boot?