Silent/quiet uboot - bananian, bananaPi M1 - update uboot

Hi there, I had completly silent boot (without any message, but with splash screen) when i was using LCD LVDS display. I needed to start using HDMI display, and when i changed the display to the HDMI display i see uboot messages before splash screen. I want to hide them too. From my research it looks like i have to build quiet u-boot by myself and update it on memory card. I was using links as below:

So i what i did:

git clone
git checkout lemaker
make CROSS_COMPILE=arm-linux-gnueabihf- BananaPi_config
make CROSS_COMPILE=arm-linux-gnueabihf- 
sudo dd if=${u-boot-dir}/u-boot-sunxi-with-spl.bin of=${card} bs=1024 seek=8

After that boot hangs. The red and green leds are on. I also tried to update uboot from the bananapi filesystem using bpi-bootsel from third link with the same result. Now, my guess is that i have wrong u-boot. Maybe from wrong branch?

Can You help me, please?

Hello, i solved my problem. It was my or my system problem with SD cart, so i was updating wrong card. Closed