Seeking BPI-M4 image

I’ve been in the struggle to use my brand new M4… no video with HDMI to VGA adapter no video with a Bravia TV, all the times a nice black screen I’ve used this images so far:

This one gets an IP address and sometimes the SSH port comes up but can’t connect its just says “connection reset” 2019-08-08-debian-10-buster-mate-desktop-preview5-tpm2-bpi-w2-m4-sd-emmc

This one gets an IP address no SSH port: 2019-06-18-ubuntu-18.04-mate-desktop-preview-1024x768-bpi-w2-sd-emmc

This two not even an IP address: 2019-06-18-ubuntu-server-16.04-aarch64-preview-bpi-w2-m4-sd-emmc 2019-08-02-debian-10-buster-lite-preview-aarch64-bpi-w2-m4-sd-emmc.img

Two weeks in my spare time, no clue, a lot of reading a lot of googling.

With the display tried to edit the files UEnv.txt and another with kernel options… nothing…

I gave up with the display and now trying to connect using SSH…

I’ve mounted the image to edit the files and read the syslog and kern.log files no clue on what’s going on…

I just want only one thing… a simple thing just connect using SSH nothing more nothing less… I just want to burn an image, turn out the thing and connect with SSH that’s it easy right?.. I’m very very frustrated with the board… in the past I used Raspberry Pi but with the high costs (in my country the board its over two hundred bucks a kits sells between 275 and 350 bucks) I think that I could make a try with this board only bang my head with the wall.

If someone have any advice, clue, anything that I could try please any suggestion will be welcome…



try the latest 2020-05-18 images, mate and server both have display and ssh work for me.

use hdmi to hdmi cable instead of hdmi to vga, default resolution is 1920x1080

i have the 1GB ram version and these prebuilt images never booted properly for me, the prolem was uboot. I built the uboot from the bpi kernel docker image and used that to boot to these images.

Thx @August I’ve tried the images that you suggest without result and two differents HDMI cables with a Bravia TV with no luck.

@shankar Please how did you do that? did you do it in a separate environment? please where did you find the instructions?

I was looking into this:

I’ve tested the Debian A10 and A20 images without any luck then I realize that I need the right images for the processor installed in the board.

Best regards


the link i provided is the correct images for m4, donot flash any other platform or board images, each board has its corresponding image. before doing this i think you should read the m4 wiki carefully, the key point is make sure the switch button is right of your board for booting linux.

Thx again for your response @August, I’ve read the wiki, its the first thing I did, I always try to do my homework :wink:

First and foremost I’ve flashed the SD card with the official images with no luck, today was a little different I’ve a small sucesss I’ve changed the SSH config to use keys because the normal way just gets me “closed connection” error and bang! I connected to the thing… then try to install packages and guess what… I get the filesystem read only error… By the way the SD card is brand new.

Geez… I tried to flash with Balena Etcher, bpi-copy and dd the same image to check if something is wrong or maybe I’m doing something wrong … I’m using Xubuntu desktop 23.04 by the way.

Maybe tomorrow I’ll give another try… I understand that BPI its different from RPI but this is very very silly.



where did you download a Xubuntu desktop 23.04 image for bananapi m4?

I mean in my desktop doc …

I think he asked about url where u download

@August are there any updated Linux images for the BPI-M4 (real team cpu) with kernel 5?