Resolution and images

Greetings guys and girls,

New here and new to BPI. Just got my first m2 zero a couple of days ago. Had a few issues that I would like clarification on.

Where and what images would be to use if I want to load raspberry pi os, why is it some images from the armbian site work and others dont.

And then on the display at 1920x1080 60hz there is screen problems where the screen tears everytime something changes. But that is not an issue at 720p 60hz. Could this possible be a cable issue. As I fear a cheap hdmi cable may be the cause. Has anybody else had these issues…

Thanks all

Why would you like to load that garbage? :grinning: That OS is only for Raspberry Pi. And works as you expect only there.

Which doesn’t work? Did you proceed with install properly:

So I went to the armbian site, selected bpi zero m2. Went through the list looking for what I wanted. Downloaded 2 buster versions, and one focal version. Both busters work. But focal the board would just not boot. So tried with bionic and raspbian and few more I cant even remember. Just not all work.

Is there something certain about the images for the bpi that is different from normal linux images?

Like this is totally a new experience for me

I see…

Just recently started to tinker with these devices. So still getting to know

There is just one Buster so i don’t know where you find the other.

Each hardware on this page needs its own image to boot. Its normal Linux (the best you will ever get for this board) … there is no BIOS on those board which means each also needs some boot loader before you can boot Linux.

Yes, its totally different.

Sweet, so the let me give armbian a look. Which would you say is the most stable image, if you could link that please. With and without a desktop.

And thanks again Igor. You have given me some good info

I found it on the page. 20.05 and 20.08.1

I just wanna say thanks for this forum, i didn’t even think that something like that existed. So once again thank you! I will be glad if I help someone too. If you have problems writing all sorts of articles but you need it in your studies, I can suggest you contact them professional writer service!

Bionic is not working for me, it just bootloops after file expansion with a message that /usr/bin/bash can not execute. This is either built or downloaded from armbian. I built it from legacy stable, and it still didn’t boot.

I tried an old bionic build from the archive feb2020 and CLI mode works, but I can’t get one to boot with a desktop.

I know this board has no official support, but do you know if there is any way for me to get Bionic working?

The images available for this board from Bpi are pretty old.


So get a professional support. Pay peoples time, not just waste it.

Official support is provided when costs we are paying for you are reasonable low. We asks you for compensation (Donation), but you don’t care since we can only cover 0.5% costs with that.

When you go outside “supported”, you have virtually no chances to get support. Anything you asks in “non supported areas” usually starts with a day(s) of research which is not something you can trigger.

Give and do something valuable. Then asks for help - you will see the difference! With your time, with things you understand and are needed and finances which we need to pay for the costs and one day hire help to help you …

Thanks for the help!