Password User pi

Hello together I now tried the two newest Ubuntu Versions for my Pi2 Berry. Software is working, but on both Versions it creates an User „pi“. What is the standard password for this account? Standard Passwords like „raspberry“ or „pi“ didnt worked. Unfotunately I didnt found any infos and I cant do much things without that Password. I also tried to reboot in recovery-mode, it didnt worked with „esc“, „1“ or „shift“. Without that Password I cannot even reboot from Terminal in recovery-mode.

Do anybody knows that Password? Thanks already now!

Have you tried “bananapi”?

If you have a linux host-system you can try to chroot into the rootfs on the card and set the password.

This is how i do it on ubuntu host for my boards (basicly depends on arch of your target device (armv7,armv8,…)

sudo apt-get install qemu-user-static binfmt-support
sudo cp /usr/bin/qemu-arm-static $targetdir/usr/bin/
#for r64/r3 use
# sudo cp /usr/bin/qemu-aarch64-static $targetdir/usr/bin/
sudo chroot $targetdir


Did you know that in recent kernel (4.8 I believe) you don’t need to copy the qemu-static anymore? At least when the binfmt is registered with the F flag, at end of registration string. Should be in /lib/binfmt.d or so. Any recent OS will have it set.

No, have to try it. Thx for information. Foujd the way with copy long time ago and never changed it :slight_smile:

Oh thank you so much, Frank, yes it is „bananapi“. Now I cannot install homebridge, because libc6 has probably too old version. But I‘ll try that to fix myself. System is offering me update to Ubuntu 18.04.6, but that wont work on an Pi m2 berry, correct?

But anyway thanks again for the Password!

Update: I tried it with Armbian and was able to install homebridge. Thanks again anyway!

You should upgrade/reinstall a newer version as ubuntu 18 will no longer supported (imho support ends this year). So time to update. You can bootstrap a newer ubuntu, and replace rootfs with this…do not forget to set root-password and maybe create user pi (with sudo) before first bootup. And for first test you should backup your current kernel-modules /lib/modules/* and /etc/fstab

Thank you, I try that on the other sd card, where Ubuntu is still installed. The Armbian from the following Link seems to base on newer Linux. And on the newest Ubuntu provided by Banana Pi Website I also cannot connect to Wifi, but I‘m not the only one with that issue. :man_shrugging:t3:

Based on vendors site wifi uses an ap6212 chip for wifi…never heard about it…i guess there is only a closed source driver (no linux mainline support)

Says you have trouble connecting wifi in armbian?