Openwrt CHAOS CALMER - Stable release, Major Bugs Fixed! - BPI R1

shared by db260178

Update 24/05/2015 - Have identified the 1 minute disconnect issue:

After debugging the rtl8192cu module, it appears the HW crypto of the rtl8192cu has a race condition causing a complete loss of data flow within a few minutes.

I’ve changed the kernel module to use the software decryption instead of relying on the HW of the rtl8192cu chip.

I haven’t had loss of data or connection since - please post if you are still having issues - Download from 24/05/15 the V1.0.0522 image for this fix!

The speed of the GMAC is still not resolved, but working on further debugging.

(Updated 22/05/2015) - Added SATA pwr to u-boot code on boot. Latest openwrt trunk source!

Hi Banana Pi owners,

Here is my release of the Openwrt Chaos Calmer for the Lamobo R1 board.

I’ve patched the official trunk sources with a SATA power Regulator fix and enabled the AHCI sunxi driver - Which works now!

I’ve patched the rtl8192cu driver to fix a deadlock issue experienced if client is connected after a few minutes.

I’ve enabled the Power ON/OFF switch - but currently acpid is not enabled to do anything with it yet! - in V1.0.0426 release.

Download - R1

Latest Please GOTO Download page!

Previous Release: OpenWrt-ImageBuilder-V1.0.0426-sunxi.Linux-i686.tar.bz2 1.1GB openwrt-V1.0.0426-sunxi-Lamobo_R1-sdcard-vfat-ext4.img 220MB (expand with Gparted to use full space)

Any problems please verify the MD5 matches as above otherwise all kind of problems will occur. Cmdline - md5sum openwrt-sunxi-Lamobo_R1-sdcard-vfat-ext4.img

The following is enabled and works:

  • Linux Kernel - 3.18.11
  • Wifi is enabled and has the latest patches to fix issues with AP mode and deadlock issues - (1 minute disconnect issue fixed in V1.0.0522 release)
  • Switch with VLAN works with default LAN IP enabled on boot - (V1.0.0522 default is
  • Recommended packages to make it work out of the box - Web interface, WPA supplicant, Disk tools (mkfs,fdisk etc), ETC ETC

The following still does not work:

HDMI output No sound

Untested: I’ve seen reports of speed issues - The GMAC glue does not run at the full 1GB/s speed, the BCM53125 does work at full speed

The Google folder has: See folder ‘Latest’ for newest version

Previous Release: OpenWrt-ImageBuilder-V1.0.0426-sunxi.Linux-i686.tar.bz2 - contains the full packages,ImageBuilder openwrt-V1.0.0426-sunxi-Lamobo_R1-sdcard-vfat-ext4.img - Just The SDCARD image to DD to an SDCARD.

On Windows use Rufus to burn to a micro SD Linux and others use DD from the command line or Suse studio USB writer.

Default LAN IP = or ( from V1.0.0522) Default user: root no password - set from going through the web interface

Connect the lamobo r1 to your pc if your router has the same IP address or use a USB ttl lead on the serial port.

Happy Routing!

Where can I find this patch?

what module are you used?? are you use R1??

I already try with some alternative version of rtl8192cu drivers but it’s not stable. The same is with the one which are inside kernel.

Yes, I am using R1 but kernel is 4.1.2