No Wifi or Bluetooth..?

Hello all, I’m pleased to say I recently bought an M3 board primarily because I wanted something with a few more features and more grunt than a Pi3 while still being able to run a version of Raspbian. I’ve run in to an issue, and I’ll be frank I’m not that great with Linux so some hand-holding may be needed:

When Raspbian boots to the desktop it claims there is no bluetooth adaptor to be found and no wireless interfaces either! I’ve gone through the rigmarole of trying the set wifi up manually as per this link:

and tried the raspi-config option to “wait for network connection during boot” just to see if that would help, even tried to disable power management to see if that would help - sadly, no. When queried the Pi stubbornly reports there is no Wifi or Bluetooth hardware available!

At this point I wondered: -Corrupt installation to SD -Broken hardware Other…? I’ve tried all the versions or raspbian available on the website with the same result, but for the 2016-07-12-raspbian-lite-bpi-m3.img which actually works fine! -Good, not a damaged board… …so I tried the usual process for updating Raspbian and adding ‘X’ and LXDE, but while my connection was working fine many of the files reported “not found” errors. I guess the M3 version of raspbian is sufficiently different you can’t actually do this.

So I’m stuck: -I’ve proven that my M3 is fully functional -But I can’t persuade it to recognise it has wifi (or bluetooth) with any of the versions of Raspbian available that I would find useful to my needs, and can’t seem to update the (for me) functioning lite version.

Out of despiration I wiped the whole /boot directory on the version of raspbian I wanted to use and copied the ‘lite’ version files in in case I was missing a driver… it’s still booted fine, but still no wifi (or bluetooth)

Can anyone suggest what I try next? (no, not another OS as my specific needs require I use a version of Raspbian)

Many thanks, Charles

PS I also tried a known-working Raspbian-compatible wifi dongle in both USB ports and this wasn’t recognised either.

BUMP: Well, I returned my M£ to the vendor on the assumption it had a broken WiFi/Bluetooth module… The vendor kindly sent me a replacement and guess what? Exactly the same!!! Seemingly the board works well but it doesn’t matter what OS/version I try the device stubbornly refuses to report available let alone functioning Wifi or Bluetooth.

So what gives? While I dislike Linux as an OS I’m not a total n00b and have had some experience trouble-shooting network issues but this is the second M3 that claims it has no such functionality. I presume one of four issues: -My second broken M3 in a row, likely? -The OS’s available for this device are missing basic support, hence not even detecting the WiFi / Bluetooth module, possible -The OS’s available are in some other way broken and so preventing this working, I can’t find anything wrong with the config files -The M3 is a fundamentally broken device in the first place and maybe I should just get a refund and not bother with Bananna and their devices in future…?

Any chance of a bit of support?


I installed Ubuntu 2017, wifi worked, but was often disabled. They say that the wifi module itself is so bad.