No sound on BPI-M3

Have no sound on BPI-M3 (Linux Ubuntu 15.10 03/12/2015 and Raspbian Jessie). I am trying to get it with HDMI and 3.5 Jack. Full silence. Help me please.

Try it

Step 1:

Step 2"

Hello. I’l tried to switch all ouputs and test in on “Hardware” tab. No results. Just silence.

Helo all. On Android audio work fine, on Ubuntu - now working. Any help?

Under root user it works, didn’t work user pi

Hi, you could check /boot/config.txt options.

  1. hdmi_drive (1 - no sound, 2 - sound)
  2. dtparam=audio (off - no sound, on - sound)

Hello guys good evening. I’m having the same issue but a little different. I just got a banana pi m3, it is working fine, the ubuntu mate seems fine too, usb ports are ok, the logitech keyboard and mouse (all in one) was just plug and use the bluetooth and wireless connection are all in good shape but the sound is not working. The banana is connected to my tv using hdmi cable but the different situation is that in the sound preferences does not appear any device. What should I do?? I mean the hdmi cable is working, the image seems fine too (tested on youtube and the image seemed fine) but no sound. By the way, I’m really new to linux enviroment. Thanks for the attention.

Hello guys, good afternoon.

Just passing here to let you know that I solved it by creating an user with all the privileges and everything just worked without effort. In case any user in the future may face the same problem, try creating an user as administrator of the system. Now I’m in love with the banana pi.