My M2U is broken?

Hello. It’s my first post. I have a M2Berry with Debian 11 and OMV6 working really good. I wanted to upgrade to an M2Ultra… but it’s been a nightmare:

  • Every Armbian is not booting. Red light just blink every 5 seconds. I’ve tried up to 10 images from 21 to 23
  • Ubuntu server falls in boot loop. The red light change to green. I download from wiki.banana-pi: (2020-04-19-ubuntu-16.04-server-bpi-m2u-sd-emmc)
  • Ubuntu desktop doesn’t show the display but at least the led change from red to blue in a loop of 2 seconds
  • Debian 9 boot until login from the same wiki page. But no ethernet light is showed and no ethernet device is recognized

I don’t know if it’s related but only sd images that have FAT partition for the kernel is changing the red colour to blue.

I’ve tried to disable mmc using a dtbo file following this steps: Banana Pi M2 Ultra boot freezing trying to scan the EMMC - Allwinner sunxi - Armbian Community Forums But not look.

I’m really desperate. Anybody have any clue of what is happening?.. hardware fail? I’m using a PSU of 3A