My Custom A31s Board RAM Problem

Hello to everyone.

I designed a custom board with AllWinner A31s. I referenced BPI-M2-V3_1 open source schemas. The PCBs were produced and I placed the materials. I had a soldering problem for a while.then 3 boards worked without problems.

I used the axp221s power chip. The voltages on the pcb are correct(and I can change the voltage values with Uboot). I connected the computer with usb. I have previously compiled linux-sunxi sun6i uboot(I did not change any settings). I use the sunxi tools to install uboot. Using sunxi-fel, I tried loading uboot like this:

        sunxi-fel.exe uboot u-boot-sunxi-with-spl.bin

but the error was in case of ram init. Data coming from uart debug :

U-Boot SPL 2017.11 (Feb 03 2018 - 12:58:59)

DRAM:Training error initialising DRAM

resetting …

I added printf to debug uboot source code, and I compiled again. I see the reset in mctl_channel_init function.

I using 2 x 256MB IS43TR16128B-125KBL DDR3 1.5v DDR3 reference voltage ~0.750v

I use 256MB of NAND flash. My next target is to boot using nand flash.But I did not finish the ram end. Can you help me? Is the problem hardware or software? Are there places I need to organize in uboot source code? thank you everyone…

My answer to my question. this problem is the problem of ram soldering.

My advice to those who want to design a special board; Be careful during the cpu selection phase. I made a mistake using a31s. GPU and sound problems. The existing linux kernels did not provide a solution. Do not start with this if you do not have sufficient knowledge. Use the popular cpu if you want to start such a project. (eg A20)The board circuit you designed to get a circuit that is more pre-tested. for example (bpi-m1). If you use different circuitry, you may have to deal with dts and fex files. If you don’t have enough information, all of this can exhaust you.


1 Like