Mount root file system on USB drive on M3


I could not change the boot parameters on any of the 3 Linux images provided … For Debian and Rasbian i cannot even find the boot parameters… the boot partition is empty.

Anyonw managed to move the root file system on a HDD on the M3 ?

thanks, Vlad.

HI vlad, Did you succeed running debian, raspbian or ubuntu on BPI M3 without error? I read on this forums that sinovoip all OS (excep android) provided are corrupted and i tried it. Only android are running smoothly. Still waiting for their final release.

Since my M3 seems to arrive today I just tried it again with the Ubuntu 15.04 image: They didn’t exchange the file on Google Drive so still corrupted:

macbookpro-tk:~ tk$ unzip -l /Users/tk/Downloads/ 
Archive:  /Users/tk/Downloads/
warning [/Users/tk/Downloads/]:  76 extra bytes at beginning or within zipfile
  (attempting to process anyway)
error [/Users/tk/Downloads/]:  reported length of central directory is
  -76 bytes too long (Atari STZip zipfile?  J.H.Holm ZIPSPLIT 1.1
  zipfile?).  Compensating...
  Length     Date   Time    Name
 --------    ----   ----    ----
4294967295  09-24-15 07:22   BPI-M3_ubuntu_15.04_hdmi.img
 --------                   -------
4294967295                   1 file

note:  didn't find end-of-central-dir signature at end of central dir.

It’s unbelievable that this is all done by a ‘company’ and not a bunch of first graders…

Very disappointed, SinoVoip company build this forum & continuing sell BPI-M3 but they not response to all clients complaints, All OS are broken please fix these problem.

I could deploy all 3 inages. I used 7zip on windows to extract and win32imager to write the image.

But as i said the image runs but impossible to change parameters on kernel. Also is quite dirty a lot of remainings from m1 and m2

I don’t think so, AFAIK @projectbananapi built this forum that is currently called official.

You extracted corrupted ZIP files to create disk images you use now. Not the best approach :smile:

Since they have no clue about software at all they simply used the BSP they got from Allwinner. Then they did nothing a few months. Now they ship the devices and now they start to realise that somethings’s wrong, eg.

And so on. You can’t expect that the OS images are working :joy:

So be prepared to use an Ubuntu installation, clone the BSP with their most recent fixes and compile BSP/kernel yourself. That’s also the only way to alter hardware initialisation by adjusting sys_config.fex files here:

They refrain from using a more recent u-boot version that would make use of script.bin so you really have to setup a build environment to change such trivial stuff like display initialisation. You should be able to adjust kernel parameters by using uEnv.txt, at least these kernel parameters are set correctly:

I have searched a lot on the Internet how to mount the root file system on the USB drive, but, found no result, but macbook pro won’t turn on helped me a lot in this regarding that provided the entire guidance on this.