[M5] Manjaro ARM Official

Hello Team,

I have been working on getting Manjaro ARM up for M5 and been trying since 2 days but it kept crashing without any logs.

Finally I have fix all the issue but now I have no ethernet using upstream kernel and dtb. eth0 error

Some Screenshot.

NEOFETCH neofetch

HTOP & NEOFETCH htop-neofetch-2021-11-30_19-43

INXI inxi-2021-11-30_19-42_1

PANFROST panfrost-2021-11-30_19-42

Official image coming soon. Once ethernet issue is fixed.

1 Like

All the Images can be found on our Git.

Images that are tagged Dev are from our unstable branch and should be used for testing only.

Manjaro ARM - BPI M5

Download options:

  • Minimal Images - (Headless use)
  • KDE-Plasma
  • MATE
  • XFCE
  • SWAY



@sinovoip Please replace the link on Wiki BPI M5 to this link Manjaro ARM - BPI M5

1 Like

Tried them all - didn’t boot (including link ‘offical’) on my new BPi M5… ;(

What do you have on emmc?
You need to have android mbox in emmc for this to boot from sdcard

I don’t think I have Android as it doesn’t boot without SD. But it receives ping on IP - not sure if it means there’s something on eMMC

how do I make sure there’s something on eMMC?

the only distro that boots is slim Debian from banana-pi site.

Flash mbox Android on emmc using the steps from bpi wiki.

Then try to boot manjaro latest image.

Can I install it on eMMC and use it without SD card?


This image is to be used with bsp uboot on emmc as the Manjaro Image does not have any uboot.

Please try this steps.

  1. Flash Android on eMMC.
  2. Boot into Android. (just to make sure it works)
  3. Flash Manjaro-ARM with etcher on sdcard.
  4. Insert SD Card and it should boot into Manjaro over sdcard.
  5. Test if everything that you want works on sdcard and make sure the time is synced to your current time.
  6. Run the Install emmc script as root. sudo /boot/install-aml-emmc.sh (This will install the same OS from SD Card to emmc).
  7. Reboot. (with sdcard to boot into sdcard once again)
  8. Reboot. (without sdcard to boot into emmc)

It seems the android image download links are down (500 Internal server error). I have the armbian image flashed to the eMMC already, but that bootloader won’t load the the Manjaro image from the SD card. I guess I need to wait until they fix the Android images.

I will upload it on my server. Will send you the link once it is uplaoded.

Update: Find it 2021-05-20-bpi-m5-m2pro-mbox-android9-emmc.zip

Filesize: 879.08mb

I have uploaded the md5sum to verify if the file is the same.

Good Luck.

After the installation to eMMC it says restart and reactivate multi-boot. I am not sure how to do that, but without the SD card it won’t boot. Do I need to do something between step 7 and 8?

Edit: I try KDE version and the GUI seems to crash/flicker/go black a lot. From SD card it boots every time, and the basic functionalities work, and I can confirm that panfrost works.

Edit2: Also do you know why free -h reports 980M (~1G) total memory instead of 4G? I can see your neofetch reports 984M only as well.

I thought My device is 1gb model but M5 is only 4gb so I need to check.

You need to restart with sdcard inserted and both into the sdcard again.

There is a small manual change you have to do.

Mount the emmc rootfs and in /etc/fstab comment out the rootfs as it is old PARTUUID.

I hope you get what I am trying to say, I will update that in the next released.

I did play around in /etc/fstab, I needed to restart from scratch due to a mistake. Still trying to make this work.

I ran

sudo blkid
/dev/mmcblk0p1: SEC_TYPE="msdos" LABEL_FATBOOT="BOOT_MNJRO" LABEL="BOOT_MNJRO" UUID="4E25-E654" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="primary" PARTUUID="d9ecb2aa-9f05-4066-a980-89d6c8b22ee1"
/dev/mmcblk0p2: LABEL="ROOT_MNJRO" UUID="ac0fe79c-a1bf-483c-9352-75deb0452255" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="primary" PARTUUID="8a268f2f-4747-4a37-aa09-490201df48ea"
/dev/mmcblk1p1: SEC_TYPE="msdos" LABEL_FATBOOT="BOOT_MNJRO" LABEL="BOOT_MNJRO" UUID="0544-4078" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="1d550000-01"
/dev/mmcblk1p2: LABEL="ROOT_MNJRO" UUID="2223eb3d-914f-4b24-b200-e08454309917" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="1d550000-02"
/dev/zram0: LABEL="zram0" UUID="43483ee0-aa94-4fa6-b174-7e47fabd6941" TYPE="swap"

mmcblk1 device is the eMMC. Then I ran

sudo mount /dev/mmcblk1p2 /mnt
sudo nano /mnt/etc/fstab

and added the content

PARTUUID=1d550000-01   /boot   vfat    defaults        0       0
PARTUUID=1d550000-02   /   ext4     defaults    0   1

Then reboot, and it still won’t boot. After putting the SD card back everything is ok, but is booted from SD card. Do you have any idea how to proceed?

What is in emmc boot partition?

Can you share Mount /dev/mmcblk1p1 to mnt ls -la /mnt/

Also cat /mnt/uEnv.ini

drwxr-xr-x  4 root root    16384 1970 jan    1 .
drwxr-xr-x 18 root root     4096 febr  10 23.23 ..
drwxr-xr-x  4 root root     8192 febr  10 23.23 dtbs
-rwxr-xr-x  1 root root      735 febr  10 23.23 emmc_autoscript
-rwxr-xr-x  1 root root      663 febr  10 23.23 emmc_autoscript.cmd
-rwxr-xr-x  1 root root 28946944 febr  10 23.23 Image
-rwxr-xr-x  1 root root  7199548 febr  10 23.23 initramfs-linux.img
-rwxr-xr-x  1 root root     4642 febr  10 23.23 install-aml-emmc.sh
drwxr-xr-x  2 root root     8192 febr  10 23.23 LOST.DIR
-rwxr-xr-x  1 root root  4194304 febr  10 23.23 u-boot-default-aml.img
-rwxr-xr-x  1 root root      268 febr  10 23.23 uEnv.ini
-rwxr-xr-x  1 root root 28947008 febr  10 23.23 uImage
-rwxr-xr-x  1 root root  7199612 febr  10 23.23 uInitrd
bootargs=root=LABEL=ROOT_MNJRO rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0 quiet splash plymouth.ignore-serial-consoles

Is there boot.ini or some file in sd card /boot/ ? Copy it over to emmc /boot/ and try to reboot

Where did you get this from? It should be bootargs=root=PARTUUID=1d550000-02