M2U Doesnt boot after kernel update with bsp

After i update kernel and uboot on sdcard banana pi doesnt boot and only one red light flashing on M2U I tried to build update to update kernel and uboot I tried this guides: 1)https://github.com/BPI-SINOVOIP/BPI-M2U-bsp 2)How To Change The Boot Logo For build i used docker image as provided but it required sources update, install bsp-tools image Output looks the same as in logo guide I tried to check difference between booting card and the broken one. Dont see difference image There is also no output on COM port, looks like it cant find uboot.

red light flashing indicate that your board bootup fail, poweron and poweroff or reset alternately. i suggest you should sort out which steps got wrong.

  1. download the latest kernel 3.10 bsp image from wiki and test whether it boot well on your board.
  2. only build the original source code without any modification and update the package to your sdcard in step 1, then plugin and bootup the board.
  3. replace the bootlogo.bmp in the right target directory you want to build, and build the source code again and update.

I tried ti update images from this sources (Debian and Ubuntu)

  1. https://download.banana-pi.dev/d/ca025d76afd448aabc63/?p=%2FImages%2FBPI-M2U%2FDebian9&mode=list
  2. https://drive.google.com/drive/folders/1rHFSulKE9r6ne1McJKJoGmkwg7-atXDK

images works on its own. It fails at the second step after kernel update

include the list of commands i did on virtual machine

sudo apt install build-essential dkms
 sudo apt-get install \
     ca-certificates \
     curl \
     gnupg \
 sudo mkdir -m 0755 -p /etc/apt/keyrings
 curl -fsSL https://download.docker.com/linux/debian/gpg | sudo gpg --dearmor -o /etc/apt/keyrings/docker.gpg
 echo \
   "deb [arch=$(dpkg --print-architecture) signed-by=/etc/apt/keyrings/docker.gpg] https://download.docker.com/linux/debian \
   $(lsb_release -cs) stable" | sudo tee /etc/apt/sources.list.d/docker.list > /dev/null
 sudo apt-get update
 sudo apt-get install docker-ce docker-ce-cli containerd.io docker-buildx-plugin docker-compose-plugin
 docker pull sinovoip/bpi-build:ubuntu12.04
  docker run --privileged -d -p 2222:22 -v /media:/media sinovoip/bpi-build:ubuntu12.04
 ssh -p 2222 [email protected] #default passwd is root
 cd /
 vim /etc/apt/sources.list
 //change soureces to old-releases
 apt-get update

git clone https://github.com/BPI-SINOVOIP/bpi-tools.git
 cd bpi-tools
 apt-get install curl pv
 sudo ./bpi-tools -u -U
 cd /
 git clone https://github.com/BPI-SINOVOIP/BPI-M2U-bsp.git
 cd BPI-M2U-bsp
 ./build.sh BPI-M2U-1080P 1
 ./build.sh BPI-M2U-1080P 6

May be i missed something

 ./build.sh BPI-M2U-1080P 6

try to install the bpi-tools and execute this command on your desktop system, not docker system.

copied SD folder from docker anyway red light after this command image tried this because second step of ./build.sh 6 looked weird with just 6 files total updated image UPD: i tried armbian images from this source https://www.armbian.com/bananapi-m2u/

they both doesnt boot(without any changes)

forget it, give up the bpi-tools, after compile successfully, plugin your sdcard with image flashed to your desktop and update the build with the following commands.

$ cd SD/bpi-m2u/
$ sudo cp -a BPI-BOOT/* /media/xxx/BPI-BOOT/
$ sudo cp -a BPI-ROOT/* /media/xxx/BPI-ROOT/

$ cd 100MB/
$ sudo gunzip -c BPI-M2U-1080P.img.gz | dd of=/dev/sdc bs=1024 seek=8
$ sync

safely remove your device.

looks like the problems were in image, so this didnt help, but i tried to build it on vitrual machine with ubuntu 16.04 from this guide http://connect.majordomohome.com/profile/461/blog/kross-kompilyaciya-yadra-dlya-banana-pi-m2u.html and it worked. It took me so long to check because i started to recieve iput/output error with diffrent sd cards and usb adapters, but anyway it works now, so thanks for support.