M2m serial connection


I’m trying to connect through the serial port however I don’t get data coming over the connection till the data rate gets to 460800, this and this line from the serial-console.txt “To use a serial port as console you need to compile the support into your kernel” seems to indicate I need to recompile the kernel.

Can anyone provide advice or a link to instructions on how to do this If it helps I’m run fedora 28 for my desktop, so doing the compilation myself shouldn’t be a problem computer power wise

any help is appreciated pheonixfire

turns out I was trying to connect through the wrong serial port, however now all I get on the connection at 115200 is garbage characters

Any help is appreciated pheonixfire

Ok, so i’m not the only one with this problem. I was going crazy!

I cant see the boot of u-boot andif i got it right you should see the boot of the internal room looking for the spl. But the serial port contains only garbage!

@hiterch95 @pheonixfire Hello, here is the m2m debug console:




I have tried the gpio serial with minicom set to 115200 I still get garbage characters Screenshot

Hello,Could you please use screen to have a try or provide me the image link?let me have a try.

I used the most recent image of ubuntu provided here:


screen gives me the same result, just to rule out a random hunch I tried it with the terminals character encoding set to one of the chinese character sets and it removes the majority of the garbage characters.

Is there any way to confirm which language it’s using for boot?

any help is appreciated


Hello, I tried the image,the print is ok.


Please confirm your usb-serial wire or does you connect the right console?


these are the usb to serial cable I’ve used, the ftdi one being the most recent



This is the adapter I’ve got going from the adapter to the pi, I can’t show the db9 end I haven’t got a screw driver to open the case


@hiterch95 are you using a serial cable directly to connect to the pi, I was able to fix my problem by using a serial to ttl converter

Here’s the circuit I used, I’m powering it off one of the 5v gpio pins

Best Regards