M2 Zero USB only recognizing one device

I recently bought two BPI M2 Zero W SBC’s and I can’t get either of them to see two USB devices plugged in at the same time. If I want to use my mouse I have to unplug my keyboard and vice-versa, even with a powered USB hub. Needless to say this is quite daunting. I can’t even load a program on to it because if I unplug the mouse to plug in the USB stick, I have no control over the machine. I’ve tried both with Armbian Jessie and Raspian Bullseye both download today, 12-18-2022 with the same issues.

Any ideas or suggestions?


About me: New part time hacker and coder, most of my experience is with Tkinter and Raspberry Pi’s. I know a little about the hardware side of things, but not enough.

try community images from here and enable usb via armbian-config -> system -> hardware

Thanks Igor, I downloaded the Kinetic distro and installed it, opened up a terminal window and typed “sudo armbian-config”. After putting in my password to get sudo privilges, the config window came up. There was no armbian-config -> system -> hardware. I went through all the options and didn’t see anything about usb. However, when I did the first install I did get the errors: “Timed out waiting for device /dev/ttyGSO” and “Dependency failed for Serial Getty on ttyGSO”. Also I have a bluetooth keyoard that I tried to install and my BPI can’t find it.


You should see something like this:


while enabling all usb ports here, following by reboot. BTW. This is Armbian software, so perhaps rather check-in here.

Thanks Igor. I had an accident and my pi is no more. I’ll have to wait for my new one to show up.