M2 Ultra boot from SATA

I want to boot the M2U from SATA (ssd) and if possible without sdcard.

Tried some tutorials and different images but I can get it to work. I tried the Ubuntu image, and the Raspbian stretch image from http://www.banana-pi.org/m2u-download.html#modal17. Tutorials used: http://nload.net/how-to-banana-pi-booting-from-ssd-using-lubuntu-raspbian/ and https://www.htpcguides.com/move-linux-banana-pi-sata-setup/

The part where th uEnv.txt has to be adjusted is a bit different. I find one in /boot/bananapi/bpi-m2u/linu There is a root part: root=/dev/mmcblk0p2 rootfstype=ext4 rw rootwait bootmenutimeout=10 datadev=mmcblk0p2

Changed it to root=/dev/sda1 rootfstype=ext4 rw rootwait bootmenutimeout=10 datadev=sda1

rebooted but nothing happens. I noticed there is also: volumioarg=imgpart=/dev/mmcblk0p2 imgfile=/volumio_current.sqsh rw rootwait

Should this be altered as well?

When this works I aiming to remove the sd card completely. Is this possible? If not can I move the boot part to a smaller sd card? I find one for the raspberry pi ( https://www.raspberrypi.org/forums/viewtopic.php?t=117820 ) but don’t know if this will work for the Banana Pi as well

That is not possible.This way works - eMMC or SPI where its available:

https://docs.armbian.com/User-Guide_Getting-Started/#how-to-install-to-emmc-nand-sata-usb with Armbian and the process is fully automatized.

armbian-config -> enter -> enter -> enter - wait — reboot.

But I don’t have armbian installed…

I found the bootable images (BPI_M2U_720P.img.z etc) which can be written with bpi-tools. But I am unable to access a second sd card to do this. I got the images from the Banana pi and stored them on my windows system but these are no vailid images according rufus…

Armbian is levels above what you are trying to use.

I got it working with Armbian, was really easy to do. Thanks for the tip

1 Like