Linux image for BPI M2 Zero

Hi, I need to download image with Linux for BananaPi M2 Zero. I saw some video on BPI Wiki on this topic but when I follow instructions I cannot find BPI M2-Zero board on armbian download site.

I am right that Armbian is the best suited for that board? Where I can download the image for SD card?

Kind regards,

Piotr Romaniuk

I found images in archive section on armbian site. BPI-M2 zero is no longer officially supported by ARMBIAN:

The m2 zero support was dropped. The M2+ image boots up and accepts user input, connects to Wi-Fi and updates apt repo.

Which image specifically did you try that worked with the BPI-M2-ZERO? I’ve tried the latest Jammy and Bullseye images for the M2+ and neither have booted. The power light flashes on for a moment before turning immediately off with no HDMI output, no connection from the USB ethernet adapter etc. Saw your post date and tried what would have been the latest at the time then (focal) and still no go. If you have the exact image you tried with confirmation it boots on the BPI-M2-ZERO H3, I’d love to give it a go!

I use “Armbian_22.08.0-trunk_Bananapim2zero_buster_current_5.15.43_Server” which was provided by user Roxas, works for me.

Banana Pi M2 Zero Image Server 30-05-22…

In all of these images I’ve found the same thing, maybe I’m just going crazy and it requires an antenna if you’re not within 30cm of your access point? Initially it complains about the .bin/.txt for the firmware not existing:

[    8.398295] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-zero.bin failed with error -2
[    8.398357] brcmfmac mmc1:0001:1: Falling back to sysfs fallback for: brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-zero.bin
[    8.449153] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-zero.txt failed with error -2

So I then create a link to brcmfmac43430-sdio.txt/.bin and that goes away, though the errors are then as follows:

[  277.631970] ieee80211 phy0: brcmf_fil_cmd_data: bus is down. we have nothing to do.
[  277.632025] ieee80211 phy0: brcmf_cfg80211_get_tx_power: error (-5)
[  284.825437] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[  284.920591] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
[  284.924984] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[  284.926147] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Mar 30 2016 11:30:56 version 7.45.77.h8.4 FWID 01-ee8a6268

I’m not sure whether this is to be expected or not? Bluetooth looks to be working, though the devices I’ve been able to pair with are closer than my AP. Placing my phone as a mobile hotspot directly next to the board results in a connection so maybe I’ve just been going crazy over nothing and it just requires an antenna to be useful?

Well, I’ll edit to add that yup, it just seems that the antenna was the problem here. I stole one from another board and there we have it, lots of networks showing up… Should have tried that earlier!

thanks for the information, WiFi will be next I’m going to configure, so will order an antenna now.

I checked dmsg and saw same errors about missing firmware, can you pls. post the symlink I have to add?

I don’t know if it actually helped/did anything but you’d just want to copy or link it with

ln -s /lib/firmware/brcm/brcmfmac43430-sdio.txt /lib/firmware/brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-zero.txt
ln -s /lib/firmware/brcm/brcmfmac43430-sdio.bin /lib/firmware/brcm/brcmfmac43430-sdio.sinovoip,bpi-m2-zero.bin

I think that’s it anyway, though as I say, it didn’t actually change anything ultimately. I still get the error about if falling back and channels being limited so I’m not sure if that’s expected or not. Good luck though :smiley:

short Feedback: I found the answer to the driver load problem and the ‘blob’ message in a raspberry forum: -> Both of those “errors” are expected - the 43438 firmware has a built-in clm_blob, and we aren’t using model-specific “nvram” .txt files.

So you do not need the links, and yes: without an Antenna you must have the WiFi Router in a 1-2 m distance

Nice document about performance btw :+1:

Ah, well that’s good to know then!

Thank you, I’ll be pumping out some more content surrounding the Banana Pi in the coming weeks, comparisons, benchmarks of additional boards etc so I’ll post those when they’re ready too :+1: