Kernel starting and nothing to do

Hello friends! I have BPI-M2 Zero with H2+ chipset. I have tried to load various armbian images to BPI board from here: https://imola.armbian.com/archive/bananapim2zero/archive/ And list of images: Armbian_21.08.1_Bananapim2zero_bullseye_current_5.10.60.img Armbian_21.08.1_Bananapim2zero_buster_current_5.10.60.img Armbian_21.08.1_Bananapim2zero_focal_current_5.10.60.img Armbian_21.08.1_Bananapim2zero_hirsute_edge_5.13.12.img

The first three images freezing after the “Starting kernel…”, but last image
a few more information:

U-Boot SPL 2020.10-armbian (Aug 08 2021 - 14:47:26 +0200)
DRAM: 512 MiB
Trying to boot from MMC1


U-Boot 2020.10-armbian (Aug 08 2021 - 14:47:26 +0200) Allwinner Technology

CPU:   Allwinner H3 (SUN8I 1680)
Model: Banana Pi BPI-M2-Zero
DRAM:  512 MiB
MMC:   [email protected]: 0, [email protected]: 1
Loading Environment from FAT... Unable to use mmc 0:1... In:    [email protected]
Out:   [email protected]
Err:   [email protected]
Net:   No ethernet found.
starting USB...
No working controllers found
Autoboot in 1 seconds
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3964 bytes read in 3 ms (1.3 MiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
202 bytes read in 3 ms (65.4 KiB/s)
11083717 bytes read in 558 ms (18.9 MiB/s)
8188608 bytes read in 398 ms (19.6 MiB/s)
Found mainline kernel configuration
34099 bytes read in 10 ms (3.3 MiB/s)
4185 bytes read in 11 ms (371.1 KiB/s)
Applying kernel provided DT fixup script (sun8i-h3-fixup.scr)
## Executing script at 45000000
## Loading init Ramdisk from Legacy Image at 43300000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    11083653 Bytes = 10.6 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
   Loading Ramdisk to 4956e000, end 49ffff85 ... OK
   Loading Device Tree to 494fd000, end 4956dfff ... OK

Starting kernel ...

[    7.501840] thermal thermal_zone0: binding zone cpu_thermal with cdev cpufreq-cpu0 failed:-22
[    8.007616] lima 1c40000.gpu: dev_pm_opp_set_regulators: no regulator (mali) found: -19
[    8.772483] debugfs: File 'Capture' in directory 'dapm' already present!
[   10.933143] Bluetooth: hci0: command 0xfc18 tx timeout
[   18.933167] Bluetooth: hci0: BCM: failed to write update baudrate (-110)
[   18.939974] Bluetooth: hci0: Failed to set baudrate

How I could understanding whats happened? Big thanks.

Is your power supply alright?

We have some boards freezing during startup and the problem was the power supply.

Try with a bigger and better power. If you can, get a 5.1V one.

Also I dont recomend the micro USB power connector. I had many problem with it. Use the 5V pins on the connector or better to put cables direct to the pads.

Thanks all! I am sorry for some little questions in this thread. I successfully launched my M2Z) Power supply current still is 0.4A with disable hdmi. I want using my M2Z as simple photo cam uses with Li-ion battery. It’s probably decrease power consumption, sleep mode with resume or something like this? I’ve tried echo mem > /sys/power/state but it not resuming and even not consumption decrease.