Install Linux Headers

I have another big problem with my M2U… To install my Wifi adapter I need the Linux headers (linux-headers-3.10.108-BPI-M2U kernel) but I can’t find them anywhere.

Here is the error: (/lib/modules/3.10.108-BPI-M2U-Kernel/build: No such file or directory.) Here is a ls in the kernel you:

I would also like to know if a 4.x kernel will ever be available and if so, in what time frame?

LG Xedon

You can try to build 4.x kernel image with

Use EXPERT=“yes” build parameter to get access to development versions. There are still some issues and there is no support but it’s worth trying.

1 Like

@igorpec ok thanks, I will test it later. currently I just need the information how to install the Linux headers on the “current” 3.10.108 kernel to install the driver for the wifi adapter

I just need the information how to install

I don’t think you will find kernel headers for this kernel that easy.

and how can I install the driver with make? There must be some way to install a normal driver or? (rtl8812au-dkms,

lg Xedon

You can’t (this easy). Those images are not on that level. And DKMS support … dream on.

With Armbain distribution, all this is possible, of course … I am not sure DKMS works perfectly well on all kernels yet, but it has good ground and can be fixed once. Armbian came with a much better 8812AU (with support for 8811 and 8814AU variants as well) driver that you are trying to compile. By default. On all kernels where it works …

I am using them, AC speed in a station or AP mode (my daily driver).

Okay, so can you tell me more about it? I have never created my own image, is there a manual or a ready-made image or can you tell me what I need to get it to run on m2u with the firmware etc? What is supported and what is not? (I need for example the Sata connector)…

If you never did this … you will need to read and experiment. Well, any way you have nothing much too loose since alternatives are much more complex and fu***d up. To access WIP section and exotics, you need to run: ./compile EXPERT=“yes”

SATA is supported.

Also make sure you read this:

1 Like

I tried the whole thing but unfortunately I had to say that it didn’t quite work out… The build process ran without problems (here the finished image: Unfortunately I had to realize that only one partition was created… The current images here in the wiki contain 2 partitions, I think it finds not the boot process, so it will completely leap the sd card on startup and start my current image from the emmc…

quite simply said the image is not booted…

Anybody have an idea?

Can’t check since I am out of the office. The only thing I can check is building logs to see if there is anything wrong. Paste logs which you find in output/debug

One partition is just fine. Current images are not a reference. They try to be Raspberry Pi like. Rpi can’t boot from EXT4 partition and must have FAT boot partition. So much about open source …

Following instructions closely at first?

Here the logs:

ok can this be the Problem? I think I have here a EXT4 Partition… How can I switch to FAT in the build process?

Yes I have installed witch the Tool “Etcher” my Image on SD Card…

This is not a problem while FAT Windows partition on a Linux system is a problem. Not so much technically but moral. Its a problem of Raspberry Pi and whole industry is copying its “technology”. Including bugs and bad practices. This is unrelated to the problem you might have.

Possible problem is this:

but you won’t be able to catch it without serial console. There are few tricks how to overcome the problem.

I build another image withing official build system. Try it and use some other SD card:

Make sure SD card is present when you power the board. If you insert it later it will boot eMMC.

thanks the image is starting ^^ but I have here no username or password :frowning:

Good! :grinning:

Now proceed with our standard manual:

thanks :smiley:

Now the next Problem… Ethernet is not working :frowning:

Expected … if everything would work, this would not be called a development/testing image :slight_smile:

There is little what we can do at this moment, other than using wireless or USB Ethernet. Someone with some clue has to check Ethernet settings within a device tree …

ah ok thanks, three last questions ^^

My SSD is not recognized… Is there anything that needs to be installed first? And I have now created an ap (the adapter supports dualband) and wanted 2.4ghz and 5ghz, both are enabled in hostap but I can only reach 5ghz, where is the error?

The ap works very well, but I can’t get the internet from my LTE module, so I set up the ap via armbian config and there “modem is online” is also displayed under LTE… Do I have to build a bridge or how did you solve it?

Nothing. It should work, well, you only need to mount it. Check power, use external powering to make sure.

At once? Not possible. You need to have one for 2.4 and another for 5Ghz. armbian-config way currently supports adding only one adapter anyway. For running more you need to supply hostapd config to hostapd manually

You don’t need bridging. IIRC you need to alter /etc/iptables definitions only …

After hours of trying I still haven’t found a solution for the ssd problem and the route problem :frowning:

The Dualband Ap now works fine but I can’t get a connection from my LTE module, so wlan there is no internet… (I tested Lte modul, works perfectly it’s somewhere on the routing I think)… I set it up according to this guide but it just doesn’t work for me:

I have adapted the iptables shown in the guide accordingly to my interfaces My LTE interface is = lte0 My wlan interface is = wlx000f0058aa61 I’m getting nowhere… maybe it’s the dns service, what have you done?

To the SSD again… There is enough power in any case, the whole thing is connected via DC and it worked on the 3.10 kernel images… (the ssd is also not displayed on fdisk).

Can you at least help me get lte to walk again?

I am travelling ATM and doing this (try this and that and report back) on a theoretical base is usually a waste of time (which I don’t have). I plan to solve this LTE management within armbian-config within a few weeks. I will look other things as well when I am back to office.