I can not give permission for transmission to access hdd

i have bananapi m2u connected with 4tb hdd by sata(ext4 format)

i installed transmission on my bananapi.and i tried to download some files , but suddenly it just stops. i didn’t know why until after many days of research. i found out that it stops after reaching size of disk cashe that i set .

and when i go to 192.168.1.***:9091 web interface, it shows error message “permission denied”;;;

i did about everything that i can find on google to solve this… but for me didn’t work;;;

plz help me…

i did

  1. chmod 777 -R /(directory)/ and give every permission to those folders

  2. sudo usermod -a -G debian-transmission root

  3. sudo nano /etc/init.d/transmission-daemon and change USER=debian-transmission to USER=root

4.i tried to add root to debian-transmission group(opposite too)

i thought it might be just can not write, but if i do ’sudo service transmission-daemon status enter image description here

i can see it can not even access to anything;;;

i think permission of that folders are just fine. i can write of delete from my main computer(windows) by samba i think transmission’s permission it self dose not have enough permission to do that…?

enter image description here

this is my permission for folder that transmission need to access… what should i do…?

//sorry for my bad english//

If you get error about permission over Web-request - it’s problem about Web server configuration. Look at transmission config in section that provide web configuration

1 Like

i usually control transmission with GUI remote but GUI does not show me error message just stops. i dont think it is web configuration problem

even i make start torrent on bananapi it does not start…

is there anyway i can check what is the permission level “transmission-daemon” it has… and change transmission’s level to root?

i mean… i used chmod 777 -R /(directory)/ and it means “i will allow anybody to write or read and delete .” right?

i dont understand what makes transmission “permission denied” now…;;;;