HOSTAPD doesn't work on bootup, only when signed in

I’m following this guide:

As long as I’m logged in, everything works fine - but when I reboot, instead of hostapd starting, I get an error message:

FAILED Failed to start Advanced IEEE 02.1#802.1X/WPA/WPA2/EAP Authenticator. See ‘systemctl status hostapd.service’ for details.

I can’t check the log because as soon as I log in, hostapd is called and running just fine.

I’ve been using this image: 2020-04-28-raspbian-stretch-bpi-m2z-sd-emmc.img

Anyone got ideas?

Hm. I’m using Raspbian, not Armbian - the raspi-config doesn’t have that option to create an AP unfortunately. Worth the try, though - thanks.

Maybe I should give Armbian another try - I’ve got spare SD cards.

Armbian is better in just about every way.