Emmc patch for m2u armbian and mainline kernel 6.1.x

The mainline kernel or Armbian 6.1.x images for bananapi m2u will hang during the kernel boot process when initializing eMMC, causing the system fail to start up. This is because the 6.1.x kernel does not support high-speed eMMC for R40, which leads to eMMC initialization failure, apply this patch sinovoip-bananapi-m2-ultra-enable-emmc.patch (2.1 KB) to fix this issue.

Is it possible you could post the compiled version. Armbian will not import if because it doesn’t have all the source libraries to compile it. It needs to be a .dtb file.

Thanks, Guy

try this images https://drive.google.com/drive/folders/12KjzRcmpUuHkbD0LYcCzzpmDQvcADEhl

I use the latest Armbian image you sent on the link and it worked great. I loaded the image after I updated it with the armbian- config to the emmc and it runs without the sd card. I noticed that the armbian site has updated their new image to work with the ultra, but have not tried it.

Thanks a lot.