[Discuss] BPI-M2 Ultra Touch doesnt work


I install ubuntu 16.04 on bpi-m2 ultra emmc. All ok but after doing this bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m2u/BPI_M2U_LCD7.img.gz nothing appens.

Touch doesnt want to work. Will be my mistake or have to do something more. Try Android and wont work too.

this image worked for me https://wiki.banana-pi.org/Banana_Pi_BPI-M2U#Ubuntu


If you have installed Ubuntu 16.04 on the Banana Pi M2 Ultra (BPI-M2 Ultra) and the touch functionality is not working, there could be several reasons for this issue. Let’s go through some troubleshooting steps to identify and resolve the problem:

  1. Verify Hardware Compatibility: Make sure that the touchscreen hardware is compatible with Ubuntu 16.04 and the Banana Pi M2 Ultra. Check the manufacturer’s specifications and documentation to ensure that the touch panel is supported.
  2. Check Drivers and Kernel Support: Confirm that the necessary drivers for the touchscreen are available and loaded in the kernel. Ubuntu 16.04 might not have the required drivers built into the default kernel. You may need to search for additional drivers or kernel modules specifically for the touchscreen you are using.
  3. Update the System: Ensure that your Ubuntu 16.04 installation is up-to-date with the latest software packages, including drivers and kernel updates. Run the following commands in the terminal:

sqlCopy code

sudo apt update
sudo apt upgrade
  1. Check dmesg for Errors: Use the dmesg command in the terminal to check the system log for any errors related to the touchscreen or the input subsystem. Look for messages that indicate problems with the touch device.
  2. Calibrate Touchscreen: If the touchscreen is detected but not working correctly, it might require calibration. There are tools available in Ubuntu that can help you calibrate the touch panel. Search for “calibrate touchscreen ubuntu” for instructions.
  3. Test Touchscreen with evtest: Use the evtest tool to verify if the touchscreen is being recognized and to check for any input events. Install evtest if it’s not already installed and run it with sudo:

Copy code

sudo apt install evtest
sudo evtest
  1. Check Device Permissions: Ensure that your user has the necessary permissions to access the touchscreen device. Sometimes, permission issues can prevent proper interaction with the touch panel.
  2. Verify Android Image Compatibility: If you also tried an Android image and the touchscreen didn’t work there either, it might indicate a hardware or compatibility issue. Verify that the Android image you used supports the touchscreen hardware on your Banana Pi M2 Ultra.
  3. Community Support: If you’ve tried all the above steps and the touchscreen still doesn’t work, consider checking forums or community support for the Banana Pi M2 Ultra or the specific touchscreen model you are using. Other users might have faced similar issues and may have found solutions.

Remember that Banana Pi devices often have different hardware configurations, and finding the right drivers and settings might require some trial and error. Be cautious when trying out solutions from various sources, and always back up important data before making significant changes to your system.


Top management consulting firms in delhi

I gonna test it and after i give you feedback Tks

I test it and after more searches i find a way to put this driver with this command modprob gtx9xxnew_ts but touch is inverted.

How to calibrate?

  1. flash 2020-04-19 ubuntu 16.04 mate desktop image

  2. After startup, switch bootloader to support bananapi 7inch panel

    $ sudo bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m2u/BPI-M2U-LCD7.img.gz /dev/mmcblk0

    $ sudo reboot

  3. After reboot, insmod tp driver, or add it to /etc/modules for auto load

    $ sudo modprobe gt9xxnew_ts


Thanks for help. Now its working.

But how i put auto load ? sorry but usualy i dont use linux… :confused:

In android have resolution for touch?

add it to /etc/modules

root@bpi-iot-ros-ai:~# cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


Tks for your helping me. Its ok now :smiley: