Can't run any images

Hey, I have a 16GB class U3 and I tried to run the latest Android 5.1.1 V4, Ubuntu 16.04 mate, Raspbian, Debian, DietPi and none of them seems to work. I used DD command and also tried the win32 disk imager. (Except for android I used PheonixCard. I don’t know what to do to make it works. Thanks


You have used SDFormatter, and the SD cards should be class 10.

What happen when you power the board? What kind of power cord are you using (USB or barrel connector)?

Hi baskwo

It will always use the hollow plug DC-IN 5V/2,5Amp., not the OTG I have no M3.

@Wolf2000 Alright, I bought a new 16GB Class 10 sd card. I’m going to give it a try. Do I have to use SDFormatter? Because I didn’t. Also I’m using a AC/DC Adapter outputing 5V DC 2A throught micro usb port.

@trvnrc It’s powering up (3 led) then it’s booting and after like 10 seconds it’s powering off. (I have a USB converter to see the output of the console if you need)

Hi Because SD Formatter has to be taken In the first version was still the USB as power supply and also had many problems, once again not the OTG use Sorry my english I come from Austria

So I need to use a “Power Supply” cable instead of micro usb + use the SDFormatter? Thanks for your help and don’t worry I’m a French Canadian my english is the best :stuck_out_tongue:

Is that one Would be good?

I have the same problem too Log bootload from console: boot_log.txt (32,2 КБ) Kernel starts to work and all reboot. And so the loop.

Hello people,

For boot problems with BPi M3 i noticed sth. about SD cards. Please make sure that your sd card is OK and healthly.

When we start testing BPi M3 we also experienced some problems with booting. Problem was with broken sd card. We replaced it with new one, for example SanDisk 32 GB and it works fine.

But i could confirm that i have a problem to run latest Android image (from 2017-01-11) //image don’t boot//.

Anyway - all other images provided by SinoVoip seems to work fine.

If you use dd command on Linux then it should write image on your sd card properly.

Warm regards Pawel

Hey, my sd card is brand new and I just tried the Ubuntu Mate img using dd if=img of=/dev/sdb (sdb is my sd card) And it stops after 10 seconds (using microUSB power)

There is the log of multiple attempt to boot

Hello Baskwo,

As my experience with BananaPi M3 i noticed that USB power in doesn’t work properly. In my case i have to used dc power in or use power in from hdd. Later i could share a photo with you. Maybe its depend on board version. Please tell me if your LED’s located on the board are blinking or not ?

There are 3 LED’s, red,green and blue ? Do anyone of them are power on ?

  1. Is dd if=img of=/dev/sdb your full command that you used to write image on sd card ?

  2. Do your desktop linux system (that one that you used for image write) recognize sd card partitions (boot and filesystem) after image write ?

Warm regards Pawel

Hi pawelw, Thank you for helping me :slight_smile: Which DC adapter did you buy? I can’t find one on Google (aka Aliexpress and some other website for electronics) My 3 leds are not blinking but constant on when booting.

The command I used was: dd if=2016-07-21-ubuntu-mate-16.04-desktop-armhf-raspberry-pi-bpi-m3-sd-emmc.img of=/dev/sdb

My desktop linux system recognize both partitions BPI-BOOT and BPI-ROOT


I solved the problem by connecting the power (5V) to the 2 output GPIO connector (yellow wire) My usb hub connect to external power 5V upto 20A, and all usb devices connect direct to this power.

Hi, thanks for your help but it is still shutting down after like 10 seconds :confused: (Didn’t know you could power up your bpi there)

Try startup to stay in uboot. Whether the RPI to reboot at uboot ?

This is the full log of when it shutdown after 10 seconds

Hello again,

No problem, lets try to think again.

This is our solution to provide power for BananaPi M3

We used 5V, 3A dc power adapter. BTW: i have to also check anper solution on our board.

I could only suppose that if your LED’s are powered on but not blinking - BPI can’t read information from sd card. In our case we 1stly have to do sth with power cause after connect to OTG it can’t work. No power, all leds were off.

Please also note that it is board v2 so i’m not sure where could be a difference.

Please try to use this command to write an image:

dd bs=4M if=system_image.img of=/dev/sdb && sync


dd bs=1M if=system_image.img of=/dev/sdb && sync

2nd command could take little longer time.

Let us know about the result.

Warm regards Pawel

Hey, I tried with your commands and I have the same result.

Hi pawelw The No.1 is not intended for the power supply, it is intended for the SATA The No.2 is the right one.