Can't Change the Boot Logo

Hello !

I want to change the boot logo to have a custom one on my Banana-Pi (I tried on the M2 zero and the M2 berry with a 16 Gb SD card).

I tried two solutions, and both does not work:

With Raspbian:

I followed this tutorial: How To Change The Boot Logo but every time I have “u-boot error 2"

With Armbian:

I tried to build new image for the Banana Pi by following the tutorial and using this : but it does not boot (black screen)

Does somebody know these errors and how to fix this? Or have other ways of doing it, I am open to different ideas.

Thanks !

Try harder :slight_smile: Check 1st if automated builds works (berry = ultra )

Automated testings shows no troubles:

OS: Armbian (22.08.0-trunk) armv7l 
Host: Banana Pi BPI-M2-Ultra 
Kernel: 5.15.69-sunxi 
Uptime: 4 hours, 14 mins 
Packages: 968 (dpkg) 
Shell: zsh 5.9 
CPU: Allwinner sun8i Family (4) 
Memory: 154MiB / 2013MiB

Thanks Yes the automated builds works ! But i still can’t make it work when i am building it myself

Did you read system requirements well? Perhaps using WSL to build image? What is inside output/debug/ logs ? Boot logo chaining procedure you are referring is 100% not compatible …

Thanks, I am using a virtual box virtual machine (ubuntu 22.04 and unbuntu mate) they have 4 threads and 3 Gb of RAM. now i have something different : image it can’t fetch some packages, does it means it is down and i have to wait or do i install them manually. i also have “errorCode=5 Too slow Downloading speed”

i am building an image for the banana-pi M2 ultra.

That is pretty irrelevant.

Try * NO_APT_CACHER ( yes | no ): disable usage of APT cache. Default yes in containers, but can be overridden

Thanks a lot now it works !

1 Like