Building kernel

Hi, Im building the kernel and Im getting

  • make[1]: Leaving directory ‘/home/wasd/bpi/BPI-M3-bsp/linux-sunxi’ Makefile:59: recipe for target ‘kernel’ failed make: *** [kernel] Error 2

My Ubuntu dist is:

  • @ubuntu:~/bpi/BPI-M3-bsp$ uname -r
  • 4.2.0-16-generic

Hi, “uname-r” shows kernel-version not ubuntu-dist

try “cat /etc/issue” to get ubuntu-version and regarding your error…the lines before that line you’ve posted are interesting…first line with error is needed.

Ive fixed it by installing another ubuntu dist, but now the BPI wont boot when i overwrite the old kernel with the new one :confused: and I’ve chaged the display modeline output to a custom resolution and the screen still doesn’t work…

Is there a log for boot up sequence?


Maybe it is the same issue as me. See:

if its help


Yeah ive got an older version of the gcc 4.8.4

Well it boots but not to Xorg only to shell and the uname -v is still the old date “Jul 13 03:32:18 2017”

without the full error-message from build we can not help you…

leaving directory is only a info with the note, that erros occured before…so please post the errors before that message

you can also do the make like this:

“make 2> >(tee error.log)”

and then give us this error.log

Well i can build now it just refuces to boot atm. I’ve only had luck once. Ive also treid to change the GCC (gcc-linaro-arm-linux-gnueabihf-4.7-2013.04-20130415_linux) aswell not working… ive been using this method to write the kernel PDF guide

Here’s the log file. I got the error again after I redownloaded the source :confused:

error.log (26.9 KB)

Here is a more relevant error log all i edited in the kernel configs is unput, im quite new to Linux platform so excuse my noobiness :sweat_smile: I saw that the light sensor was enabled by default in melicious input so all i got enabled there now is uinput

here is the makefile line that it throws at:

$(obj)/resume1.code: $(obj)/resume1.bin $(Q)$(obj)/gen_check_code $(obj)/resume1.bin $(obj)/super/resume/resume1.code rm -rf *.o $(obj)/../*.o

error.log (2.1 KB)

Okay i switched dist. now I can build i changed to x64 but on boot i got error

Failed to insert vm149c_act: Exec format error

Failed to insert ov8865_4lane format error

Failed to insert vfe_v412 format error

Failed to insert pvrsrvkm format error

you compile kernel using

Yes, I compiled with

Now im trying to build on the bpi instead but im getting tons of errors now


First you must install git before using git clone :slight_smile:

Ive installed git, I’ve installed all the dependency packages I still getting that error, I’m building with the latest Ubuntu-Mate-beta-1 that has been released on the forum, the format error was that when I compile on x86_64 some code wasn’t compiled as arm for some reason so I decided to compile on the bpi instead but then I get missing GCC header 5 as well as some led functions issues of what I can see in the error log. But I’m not a Objective C programmer, I used to work with C#, I had tryed to install the GCC 5 package and it did nothing. Could it be because I’m compiling on a external drive? Sorry for the noob questions I know its cinda annoying but im new to Linux.