Build BPI-M2Z-bsp bsp fail for BPI-P2 zero

Hi all,

I want to make an image for P2 zero, so I downloaded the “BPI-M2Z-bsp” project from git hub to build, but something went wrong!

But another download BPI-M2P-bsp-4.4 is a build success.

Build environment:

  1. Use docker for sinovoip/bpi-build-linux-4.4

  2. ./ BPI-M2Z-720P

Could you teach me how to solve it? Thanks a lot.

Hello, I just tried to build the latest code BPI-M2Z-bsp, I could build successfully.

In your log, there is something wrong with Makefile at line 150 and line 53. But it should not have error.

Did you use the latest code?

Hi ZB,

Yes, I use “git clone” get lastest code, and use docker build environment for “sinovoip/bpi-build-linux-4.4”.


For Linux bsp kernel 3.4 and kernel 3.10, build with docker image bpi-build.

For Linux bsp kernel 4.4, build with docker image bpi-build-4.4


Hi August,

I downloaded the docker image bpi-build according to your suggestion, but the result is still the same failure. :sob:

。。。。 。。。。 。。。。

I have the same problem!

The kernel is successfully compiled, the error appears only when building u-boot. The same situation for 3 and 4 cores.

apt-get -y install net-tools && apt-get -y install iputils-ping

apt-get -y install gcc-arm-linux-gnueabi

apt-get -y install gcc-arm-linux-gnueabihf

apt-get -y install gcc-aarch64-linux-gnu

apt-get -y install device-tree-compiler

apt-get -y install git && apt-get -y install make && apt-get -y install gcc

apt-get -y install bc && apt-get -y install cpio

apt-get -y install libncurses5-dev && apt-get -y install libncursesw5-dev && apt-get -y install lib32ncurses5

apt-get -y install lib32stdc++6 && apt-get -y install lib32z1 && apt-get -y install bzip2

apt-get -y install u-boot-tools && apt-get -y install lzma && apt-get -y install busybox

or you could use my docker image:

docker pull jackzengcn/bpiboardbuild:latest

Same error but can resolved with

apt install python swig libpython-dev

these resolve all errors images