BPI won't start at all

Hey guys,

just got a new BananaPi M2-U and it won’t start at all. I tried three different microsd-cards, but the only thing I get is the red LED lighting up for two seconds, and the green and blue leds blinking once, after that the red LED turns off again.

Flashed the image on Mac via:

sudo dd bs=1m if=2018-05-24-raspbian-jessie-preview-bpi-m2u-sd-emmc.img of=/dev/rdisk2 conv=sync && sync

which worked on my other Bananapi without problems. Tried pressing the power button for 10secs as well.

Do you have any suggestions or tips? Or ist the hardware probably dead?

Thanks in advance! :slight_smile:

Okay got it to start, but I need to put power to the USB- OTG Port, DC-IN doesn’t seem to be enough… Is this normal?

hab das gleiche problem, power über usb, 2,5 watt netzteil. rote led geht an, sonst gar nichts, hab ubuntu image auf 16 gb sd karte. bei reset knopf rote led kurz aus, dann das gleich, kein signal am hdmi-display

Okay I am really not sure what to think about all this anymore:

  1. The device will power up, but just with otg hooked up to a powersupply, the barrel jack doesn’t seem to make any difference whether it’s plugged in or not. The microusb- powersupply I used all the time on my old BananaPi doesn’t seem to work, though an old smartphone charger with just 1A does work. (doesn’t make any sense either to me)
  2. I think I tried out up to 8 different images right now, every single one of them crashed while booting except one, but I cannot login in the working system as I don’t know the root- password (the one mentioned in the thread seems to be wrong)
  3. I tried out three ways of flashing sd-cards and four different kind of sd-cards, doesn’t seem to make any difference.

What do you think? Seems to be broken hardware? I cannot imagine that all those images are broken, and I’m pretty sure this device is supposed to run with 5V 2A at the barrel jack?!

EDIT: so I flashed some other Debian-stretch version but it ended in a bootloop again. Only thing that comes to my mind is to go around the sd-card and flash directly to the emmc, though I don’t know if thats so easy or possible anyway…

But I’m close to give up on this, I think there is something wrong with the hardware…

Thats what I get when I try to use the barrel jack OR a proper 2A usb- powersupply connected to the otg- port. Not when I use and old 1A smartphone-charger though…

Okay, it runs now, but other than I expected. I could solve my booting-problems by getting another sd-card which works fine now. The old one had lost some of its capacity and right now I am not able to get it back. Fdisk shows “unallocated space”… whatever…

Maybe someone can help me with a few weird things:

  1. The pi wont startup without a power supply hooked up to the otg- port. Thats not right is it?
  2. When connecting an hdd with S-ATA it won’t spinup unless I connect another power supply to the barreljack. So I need to run this device with two powersources at the same time. Thats not like it has been designed I think?
  3. I copied the system to the internal emmc with “bpi-copy”, but I never got it to boot without an sd card inserted. It wont even power up to any stage when I don’t have a card inside, is there a setting to this?


BPI is the best for everyone. Most of the pc lover they used it with externally. I also used it but I faced a problem and also I found the solutions for it. If you want to know it then follow the site which you want. xerox printer

Dear herrmann4, direct to your questions:

  1. I use a Bananapi-M2 ultra only with one 5V DC power supply - the one what is normally called coaxial connector, but i only use a SATA - SSD instead of a rotating HD nothing else. Consider to use the right SATA + Power supply adapter. I did this already with the BPI-M1, but now with this older one I have problems with the SATA socket. Seems there is defect contact.
  2. I recomment to use a serial to usb adaptor to follow the complete boot cycle including the u-boot phase.
  3. In boot-partition there is a file named uEnv.txt with a line like: root=/dev/mmcblk0p2 rootfstype=ext4 rw rootwait bootmenutimeout=10 datadev=mmcblk0p2 this means that you boot from sdcard. I use instead: root=/dev/sda1 rootfstype=ext4 rw rootwait bootmenuetimeout=10 datadev=sda1 _console_suspend consoleblank=0 where sda1 is normally the HD on SATA-Port. Im am using 3.10.108 and only with this version both the sdcard and the copied emmc boot is possible. I other case it will always boot from sdcard. regards
1 Like

Hello,please see here:http://wiki.banana-pi.org/Getting_Started_with_M2_Ultra_/_Berry#Load_your_first_image_on_M2U