[BPI-R3] Which GPON ONU is working?

well, that’s strange that we need Quirks, while in debian it works without anything special… i used the image here : https://wiki.banana-pi.org/Banana_Pi_BPI-R3#Debian

As daniel already told you they made the sfp dump by ignoring all features. Why it is pingable i don’t know,but it is not debian…it is the vendor kernel. Maybe @dale can look if it contains already a quirk for this sfp

I see an alcatel and an huaweis but have not compared with the values above.

Seems both sfp already having a quirk in mainline and vendor-code has no differences here (except the different structure).

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/net/phy/sfp.c#n441

Maybe they were added later and not backported to openwrt?

yes looks like they are here !

What about throwing in all quirks/fixups, just to see if we get something going on, can remove later, once it works.


static void my_quirk(const struct sfp_eeprom_id *id,
				unsigned long *modes,
				unsigned long *interfaces)
{
	pr_info("MY QUIRK IS BEING APPLIED!\n");

	/* Ensure that the MAC does not try to use inband-neg which probably fails */
	linkmode_clear_bit(ETHTOOL_LINK_MODE_Autoneg_BIT, modes);

	linkmode_set_bit(ETHTOOL_LINK_MODE_2500baseX_Full_BIT, modes);
	__set_bit(PHY_INTERFACE_MODE_2500BASEX, interfaces);
}

static void my_fixup(struct sfp *sfp)
{
	pr_info("MY FIXUP IS BEING APPLIED!\n");

	sfp->module_t_start_up = T_START_UP_BAD_GPON;
	sfp->tx_fault_ignore = true;
	sfp->state_hw_mask &= ~(SFP_F_TX_FAULT | SFP_F_LOS);
}

	SFP_QUIRK("ALCATELLUCENT", "G010SP", my_quirk, my_fixup),

T_START_UP_BAD_GPON means better to wait 60 seconds before tryong to ping.

I was also wondering how the IP setup should be on an ONU, since I do not have one and cannot really use one either.

Is it reachable by ssh on the ip added with ip addr add ..... eth1 ?

Or is the module reachable by ssh under some fixed (programmable) ip? Should we then need to ip addr add ..... eth1 under the same subnet a different number?

My guess is that it has it’s own ip number right?

So ip addr add 162.168.20.1 and the module is programmed at 162.168.20.10?

Oops typo 192 of course :wink:

I also read somewhere, that some of them are only reachable if also the fiber is plugged in and has a signal. https://github.com/hwti/G-010S-A/issues/24

they are reachable by SSH, yes. sometimes by telnet too. So from there you can set the ip/mask/gateway you want.

in my case they are both reachable even if there is no fiber cable connected, i tested with the media converter.

if you want to know more about ONT GPON, here is the bible : https://hack-gpon.org/

Is it set at 2.5Gbps? What speed does your mediaconverter use?

it is limited to 1Gbps

Kernel log:

But the module is set at 1Gbps? That does not sound right…

the module is 2.5g/1g i guess there is auto negotiation

i was answering to this question :

What speed does your mediaconverter use?

the media converter is limited to 1G. The module is 2.5G/1G.

On the page of your product there was a speed setting mentioned. Better not to rely on auto negotiation at 2.5Gbps between MAC and SFP

But setting at 2.5 then cannot use the converter anymore…

it’s weird that it works with the media converter then. try this one:

it includes all fixups for both of your modules

oh and i’ve included ethtool

You could set the bpi-r3 port to 1Gbps with a devicetree overlay and see if you have more luck at this speed…

That will be really helpful . What also could help is adding the debug information. Add

#define DEBUG 1

At the top of the files sfp.c sfp-bus.c and phylink.c. There are other ways, but I do not know if openwrt has dynamic debug enabled

hi !

here is my bootlog : https://pastebin.com/DR3k1uuD

i inserted the G-010S-P after it finished to boot.

root@OpenWrt:/# logread | grep 'eth1'
Fri Sep  1 21:45:53 2023 kern.info kernel: [    1.120254] mtk_soc_eth 15100000.ethernet eth1: mediatek frame engine at 0xffffffc009680000, irq 136
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.693352] mtk_soc_eth 15100000.ethernet eth1: configuring for inband/2500base-x link mode
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.703853] br-wan: port 1(eth1) entered blocking state
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.709115] br-wan: port 1(eth1) entered disabled state
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.714864] device eth1 entered promiscuous mode
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.721269] br-wan: port 1(eth1) entered blocking state
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.726515] br-wan: port 1(eth1) entered forwarding state
Fri Sep  1 21:45:56 2023 kern.info kernel: [   21.539458] br-wan: port 1(eth1) entered disabled state


root@OpenWrt:/# logread | grep 'sfp'
Fri Sep  1 21:45:53 2023 kern.info kernel: [   11.849417] sfp sfp-1: Host maximum power 3.0W
Fri Sep  1 21:45:53 2023 kern.info kernel: [   11.854570] sfp sfp-2: Host maximum power 3.0W
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.661598] mt7530-mdio mdio-bus:1f sfp2: configuring for inband/2500base-x link mode
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.671522] br-lan: port 5(sfp2) entered blocking state
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.676780] br-lan: port 5(sfp2) entered disabled state
Fri Sep  1 21:45:56 2023 kern.info kernel: [   20.684318] device sfp2 entered promiscuous mode
Fri Sep  1 21:46:11 2023 kern.info kernel: [   36.118738] sfp sfp-1: module ALCATELLUCENT    G010SP           rev 10   sn ALCLFAB44018     dc 161205
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.191915] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.198701] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.205481] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.212265] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.219106] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.225885] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.234452] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.329215] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.335993] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:11 2023 kern.err kernel: [   36.346452] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:16 2023 kern.warn kernel: [   41.242455] sfp_soft_get_state: 53 callbacks suppressed
Fri Sep  1 21:46:16 2023 kern.err kernel: [   41.242471] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:16 2023 kern.err kernel: [   41.362454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:16 2023 kern.err kernel: [   41.474454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:16 2023 kern.err kernel: [   41.586456] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:17 2023 kern.err kernel: [   41.698454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:17 2023 kern.err kernel: [   41.810454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:17 2023 kern.err kernel: [   41.922460] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:17 2023 kern.err kernel: [   42.034455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:17 2023 kern.err kernel: [   42.146454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:17 2023 kern.err kernel: [   42.258477] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:21 2023 kern.warn kernel: [   46.322454] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:21 2023 kern.err kernel: [   46.322470] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:21 2023 kern.err kernel: [   46.442455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:21 2023 kern.err kernel: [   46.554455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   46.666455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   46.778453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   46.890454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   47.002455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   47.114453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   47.226482] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:22 2023 kern.err kernel: [   47.338456] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:26 2023 kern.warn kernel: [   51.402455] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:26 2023 kern.err kernel: [   51.402468] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:26 2023 kern.err kernel: [   51.522454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:26 2023 kern.err kernel: [   51.634455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   51.746455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   51.858453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   51.970453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   52.082491] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   52.194459] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   52.306479] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:27 2023 kern.err kernel: [   52.418453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:31 2023 kern.warn kernel: [   56.482453] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:31 2023 kern.err kernel: [   56.482465] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:31 2023 kern.err kernel: [   56.602457] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   56.714455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   56.826454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   56.938454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   57.050453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   57.162455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   57.274478] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   57.386457] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:32 2023 kern.err kernel: [   57.498454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:36 2023 kern.warn kernel: [   61.562454] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:36 2023 kern.err kernel: [   61.562467] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   61.682455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   61.794454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   61.906454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   62.018454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   62.130455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   62.242455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   62.354454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   62.466453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:37 2023 kern.err kernel: [   62.578453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:41 2023 kern.warn kernel: [   66.642454] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:41 2023 kern.err kernel: [   66.642463] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   66.754454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   66.866453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   66.978454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   67.090455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   67.202461] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   67.314454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   67.426455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:42 2023 kern.err kernel: [   67.538454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:43 2023 kern.err kernel: [   67.650456] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.warn kernel: [   71.714452] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:47 2023 kern.err kernel: [   71.714457] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   71.826453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   71.938455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   72.050454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   72.163824] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   72.274455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   72.386454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   72.498453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:47 2023 kern.err kernel: [   72.610453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:48 2023 kern.err kernel: [   72.722455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.warn kernel: [   76.786453] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:52 2023 kern.err kernel: [   76.786467] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   76.906454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   77.018454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   77.130454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   77.242455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   77.354454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   77.466453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:52 2023 kern.err kernel: [   77.578454] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:53 2023 kern.err kernel: [   77.690453] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:53 2023 kern.err kernel: [   77.802455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:57 2023 kern.warn kernel: [   81.866452] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 21:46:57 2023 kern.err kernel: [   81.866468] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:57 2023 kern.err kernel: [   81.986455] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 21:46:57 2023 kern.err kernel: [   82.098492] sfp sfp-1: failed to read SFP soft status: -6




root@OpenWrt:/# ethtool eth1
Settings for eth1:
        Supported ports: [ FIBRE ]
        Supported link modes:   2500baseX/Full
                                1000baseX/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  2500baseX/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 2500Mb/s
        Duplex: Full
        Auto-negotiation: on
        Port: FIBRE
        PHYAD: 0
        Transceiver: internal
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: no
root@OpenWrt:/#

created the ont interface on ip 192.168.20.1

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd21:0974:9b37::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'sfp2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'

config device
        option name 'eth1'
        option macaddr '8a:a6:61:e6:72:c6'

config device
        option name 'wan'
        option macaddr '8a:a6:61:e6:72:c6'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'

config interface 'ont'
        option device 'eth1'
        option proto 'static'
        option ipaddr '192.168.20.1'
        option netmask '255.255.255.0'

restarted the network

root@OpenWrt:/# /etc/init.d/network restart
'radio0' is disabled
'radio1' is disabled
[  571.872247] device lan1 left promiscuous mode
[  571.876719] br-lan: port 1(lan1) entered disabled state
[  571.896695] device lan2 left promiscuous mode
[  571.901204] br-lan: port 2(lan2) entered disabled state
[  571.922615] device lan3 left promiscuous mode
[  571.927157] br-lan: port 3(lan3) entered disabled state
[  571.948528] device lan4 left promiscuous mode
[  571.952989] br-lan: port 4(lan4) entered disabled state
[  571.976095] device sfp2 left promiscuous mode
[  571.980537] br-lan: port 5(sfp2) entered disabled state
[  572.026583] device eth1 left promiscuous mode
[  572.031119] br-wan: port 1(eth1) entered disabled state
[  572.043731] device wan left promiscuous mode
[  572.048211] br-wan: port 2(wan) entered disabled state
[  572.064567] mtk_soc_eth 15100000.ethernet eth0: Link is Down
root@OpenWrt:/# [  573.526862] mtk_soc_eth 15100000.ethernet eth0: configuring for fixed/2500base-x link mode
[  573.535277] device eth0 left promiscuous mode
[  573.535295] mtk_soc_eth 15100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
[  573.543848] mt7530-mdio mdio-bus:1f lan1: configuring for phy/gmii link mode
[  573.558283] br-lan: port 1(lan1) entered blocking state
[  573.563503] br-lan: port 1(lan1) entered disabled state
[  573.569825] device lan1 entered promiscuous mode
[  573.574433] device eth0 entered promiscuous mode
[  573.589629] mt7530-mdio mdio-bus:1f lan2: configuring for phy/gmii link mode
[  573.599680] br-lan: port 2(lan2) entered blocking state
[  573.604940] br-lan: port 2(lan2) entered disabled state
[  573.611722] device lan2 entered promiscuous mode
[  573.623673] mt7530-mdio mdio-bus:1f lan3: configuring for phy/gmii link mode
[  573.633725] br-lan: port 3(lan3) entered blocking state
[  573.638971] br-lan: port 3(lan3) entered disabled state
[  573.645847] device lan3 entered promiscuous mode
[  573.657763] mt7530-mdio mdio-bus:1f lan4: configuring for phy/gmii link mode
[  573.667792] br-lan: port 4(lan4) entered blocking state
[  573.673031] br-lan: port 4(lan4) entered disabled state
[  573.680101] device lan4 entered promiscuous mode
[  573.689141] mt7530-mdio mdio-bus:1f sfp2: configuring for inband/2500base-x link mode
[  573.698614] br-lan: port 5(sfp2) entered blocking state
[  573.703852] br-lan: port 5(sfp2) entered disabled state
[  573.711099] device sfp2 entered promiscuous mode
[  573.723488] mt7530-mdio mdio-bus:1f wan: configuring for phy/gmii link mode
[  573.733929] br-wan: port 1(wan) entered blocking state
[  573.739115] br-wan: port 1(wan) entered disabled state
[  573.745506] device wan entered promiscuous mode
[  573.759154] mtk_soc_eth 15100000.ethernet eth1: configuring for inband/2500base-x link mode
[  573.818140] mtk_soc_eth 15100000.ethernet eth1: Link is Up - 2.5Gbps/Full - flow control off
[  573.826652] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  573.874326] mtk_soc_eth 15100000.ethernet eth1: Link is Down
[  574.562102] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

root@OpenWrt:/# ping 192.168.20.10
PING 192.168.20.10 (192.168.20.10): 56 data bytes
^C
--- 192.168.20.10 ping statistics ---
32 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:/#

No ping…

I can make the debug printing works either way, but I’m busy now so it will be later today

Now i’m going to use the media converter, so i plug the G-010S-P in, and connect the RJ45 cable to the BPI-R3 wan port.

i modify my network conf file like this :

config interface 'ont'
        option device 'br-wan'
        option proto 'static'
        option ipaddr '192.168.20.1'
        option netmask '255.255.255.0'

i restart the network

i wait 30s to let the ONT boot, and i do a ping

root@OpenWrt:/# ping 192.168.20.10
PING 192.168.20.10 (192.168.20.10): 56 data bytes
64 bytes from 192.168.20.10: seq=0 ttl=64 time=0.447 ms
64 bytes from 192.168.20.10: seq=1 ttl=64 time=0.304 ms
64 bytes from 192.168.20.10: seq=2 ttl=64 time=0.356 ms
64 bytes from 192.168.20.10: seq=3 ttl=64 time=0.311 ms
64 bytes from 192.168.20.10: seq=4 ttl=64 time=0.348 ms
64 bytes from 192.168.20.10: seq=5 ttl=64 time=0.293 ms
^C
--- 192.168.20.10 ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 0.293/0.343/0.447 ms
root@OpenWrt:/#

it works. i can ping the module, ssh, etc…

root@OpenWrt:/# ssh 192.168.20.10 -l ONTUSER
[email protected]'s password:


BusyBox v1.22.1 (2021-09-18 10:30:59 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

 OpenWrt - (14.07_ltq) --- Lantiq Edition for GPON
 ----------------------------------------------
root@SFP:/home/ONTUSER#

great news, so it need a link on the interface as i thought…or at least something to receive the packets (like the bridge here)

This commit:

Explains everything about the read errors. After this patch in 2019 it does not fall into the error state.