[BPI-R3] Which GPON ONU is working?

You have a typo in ip address :wink:

:rofl::rofl::rofl::rofl: THANKS !!!

some of you having a snapshot working with your ONT SFP, please share a link so we can test it with our equipment ! Thanks a lot !

Perhaps work with older snapshot 2023-04-20, I use 2.5GbE sfp to rj45 and I haven’t had any issues.

i don’t have any issues too, with a tplink 2.5g sfp to rj45. Looks like the poblem occures only with ONT SFP…

Then I am curious why it does not work on openwrt, but it does on debian.

I did not understand that part from the above…

and now my BPI-R3 doesn’t want to boot from sdcard anymore ?!

all jumpers are high, and i keep getting this message

Using ethernet@15100000 device
TFTP from server; our IP address is
Filename 'openwrt-mediatek-filogic-bananapi_bpi-r3-initramfs-recovery.itb'.
Load address: 0x46000000
Loading: *
ARP Retry count exceeded; starting again
Wrong Image Format for bootm command
ERROR: can't get kernel image!
* spi-nand0
  - device: spi_nand@1
  - parent: spi@1100a000
  - driver: spi_nand
  - type: NAND flash
  - block size:        0x20000 bytes
  - page size:         0x800 bytes
  - OOB size:          64 bytes
  - OOB available:     24 bytes
  - 0x000000000000-0x000008000000 : "spi-nand0"
          - 0x000000000000-0x000000080000 : "bl2"
          - 0x000000080000-0x000000380000 : "factory"
          - 0x000000380000-0x000000580000 : "fip"
          - 0x000000580000-0x000008000000 : "ubi"
Using ethernet@15100000 device
TFTP from server; our IP address is
Filename 'openwrt-mediatek-filogic-bananapi_bpi-r3-initramfs-recovery.itb'.
Load address: 0x46000000
Loading: *

i’ll try to help you, hold on i’m building a test firmware for you (it includes lots of stuff you probably don’t want, just check if your sfp module works)

thanks but now what ever i burn on my sdcard, nothing boot. looks like the sdcard is not detected, or it try to boot from nand ??

https://easyupload.io/x80su7 try this, i’ve created a patch for your module, let me know if that helps

finaly it worked with another sdcard…



i still can’t ping the ont

i created my ont interface, added it the ip address and added it in the firewall wan zone. everything is correctly configured, but it still doesn’t want to respond to the ping.

the problem = i can’t ping the ont, so no ssh, it just doesn’t work.

The ont is working, i can access it if i put it in a media converter (MC220L) and connect it to the wan port. that way i can access to its ip, and of course i can access internet.

now I wonder if I’m waiting long enough for the sfp to boot… :roll_eyes:

since, i made this from the ONT : fw_setenv asc0 1


if i remember well, this wasn’t necessary with Debian. And with openwrt, if it fixes the error message, it doesn’t fix the problem anyway.

a ping/access normally need 2 ip adresses in same subnet (if not completely locally)…

please share your ip configuration (ip a)…if your ONT has as ip address imho you need another one e.g. on a dummy bridge

with openwrt i just need to create a new interface on eth1, give it the ip address, and add it in the firewall wan zone. that’s enough, and that 100% works if i do it with the wan(rj45) port. my ONT is on ip

i can’t do ‘ip a’ actually i’m in my office, i’ll be back home later


I see you can edit the eeprom vendor and model ID.

static void sfp_fixup_halny_gsfp(struct sfp *sfp)
	/* Ignore the TX_FAULT and LOS signals on this module.
	 * these are possibly used for other purposes on this
	 * module, e.g. a serial port.
	sfp->state_hw_mask &= ~(SFP_F_TX_FAULT | SFP_F_LOS);
	SFP_QUIRK_F("HALNy", "HL-GSFP", sfp_fixup_halny_gsfp),

So perhapse you can edit

Setting SFP vendor name
fw_setenv sfp_vendor_name "YOUR_SFP_VENDOR_NAME"

Setting SFP part name
fw_setenv sfp_part_name "YOUR_SFP_PART_NAME"

And pretend it is the HALNy HL-GSFP module, so the quirk is activated.

Then assuming it shows the correct speed (2.5Gbps) also in the eeprom, then you should be pretty close to a solution.


But it depends which kernel version is running, as this quirk is introduced in kernel 6.1…

Ho ! interesting.

i’ll see if i can do that in a few hours…

Check the kernel version, as this quirk is introduced in kernel 6.1…

i’m actually with the firmware made by @Dale so i don’t know…

Perhapse @Dale can check if the quirk is in drivers/net/phy/sfp.c as he build it from the source…

Or he can add it to the patch he made…

I’ve added the MA5671 quirk for his module .it’s not the halny one