[BPI-R3] ubuntu 22.04 Image


i have created a basic ubuntu 22.04 image with kernel 6.1.12/uboot 2023.01

made not much tests with it, but it boots up and applies network-setting i copied from my debian-image ( on wan-port, on lan-ports). So it can be a base for further configuration.


login: root:bananapi

also added service-files for rc.local and hostapd

have not figured out how to set regdomain as it stays always 00, maybe this is the only way:

https://github.com/raspberrypi/rpi-imager/issues/511 tried way with cmdline too…not working ;( currently have no idea how to set the regulatory domain


got wifi working…

  • cfg80211 needs to be compiled as module to load regulatory.db from rootfs (installed via package wireless-regdb or downloaded from kernel.org regulatory.db + regulatory.db.p7s)
  • CONFIG_CFG80211_WEXT=y is needed else you get error “nl80211 not found” when using iw
  • wifi-module ist not loaded at system bootup. create a file /etc/modules-load.d/mt7915.conf with content “mt7915e” and reboot, then both hostapd came up at bootime

i got a error in uboot that partition 5 was not found after mutliple boots, this is how i solved it:

sudo sgdisk --backup=bpi-r3_sgdisk.gpt /dev/sdb
sudo sgdisk --load-backup=bpi-r3_sgdisk.gpt /dev/sdb

i guess problem is that partition table at beginning of card does not match the backup gpt at the end (which is not overridden by image)

1 Like

Hey how’s it going? I can’t upload the Wi-Fi module in debian, see the information:

root@bpi-r3:~# uname -a

Linux bpi-r3 6.1.20-bpi-r3-main #7 SMP Sat Mar 18 22:35:22 UTC 2023 aarch64 GNU/Linux

root@bpi-r3:~# zgrep -i ‘cfg80211’ /proc/config.gz


root@bpi-r3:~# dmesg | grep 80211

[ 5.257581] cfg80211: Loading compiled-in X.509 certificates for regulatory database

[ 5.268134] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’

[ 5.330993] cfg80211: loaded regulatory.db is malformed or signature is missing/invalid

I tried to install via:

apt install wireless-regdb crda


then I tried:

wget wget https://mirrors.edge.kernel.org/pub/.../wireless-regdb-2023.05.03.tar.gz

tar xvf wireless-regdb-2023.05.03.tar.gz

cd wireless-regdb-2023.05.03


make install


PS: I also tried with kernel 6.1.22

And still without success.

Have you loaded mt7915e module? What does dmesg say about this?


Could the error in regulatory.db prevent the module from loading?

See dmesg:

[ 13.265177] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’

[ 13.296083] EXT4-fs (mmcblk0p6): re-mounted. Quota mode: disabled.

[ 13.342079] cfg80211: loaded regulatory.db is malformed or signature is missing/invalid

[ 13.692003] systemd-journald[1107]: Received client request to flush runtime journal.

[ 13.712646] systemd-journald[1107]: File /var/log/journal/f223b6b9f19a4af09caff671d8e9d1c1/system.journal corrupted or uncleanly shut down, renaming and replacing.

[ 13.965786] mt7986-wmac 18000000.wifi: HW/SW Version: 0x8a108a10, Build Time: 20221012174743a

[ 14.132772] mt7986-wmac 18000000.wifi: WM Firmware Version: ____000000, Build Time: 20221012174805

[ 14.204623] mt7986-wmac 18000000.wifi: WA Firmware Version: DEV_000000, Build Time: 20221012174937

[ 34.405019] mt7986-wmac 18000000.wifi: Message 00000002 (seq 9) timeout

[ 34.411641] mt7986-wmac 18000000.wifi: Failed to start WA firmware

[ 34.418089] mt7986-wmac: probe of 18000000.wifi failed with error -110

No, regdb is not needed for driver to load…it is only needed to start Accesspoint in 5ghz and above

What kind of usb2serial adapter do you use? Only ftdi are known to work without issues. Most others prevent wifi fronent to start with a error similar to this

I’m using this model, I already ordered an FTDI and I’m waiting for it to arrive.

Unfortunately all the kernels and tests performed were with this USB2SERIAL connected to the BPI-R3 :frowning:

14 22

As soon as it arrives I will carry out new tests with the FTDI

Thanks in advance for your attention.

You could configure your network and users with the adapter,booting up without it and then work through ssh to check if this is the rootcause

I used FTDI and turned on the BPI-R3 and the Wi-Fi went up.

I never imagined that the incorrect USB2SERIAL could bring so many problems.

LOL :slight_smile:

Thank you very much!