[BPI-R3] Settings not saved


Just bought a Banana Pi R3.

Wrote the “mtk-bpi-r3-SD-WAN1-RJ45-20220928-single-image.img” image to the SD card (a brand new 32GB and an old 4GB, too) on Windows with Win32DiskImager. When I boot from the cards, everything seems to work, but after reboot all settigns lost. What am I doing wrong?

I tried to wipe the fs headers (wipefs under Ubuntu) as it was mentioned in the “booted in emmc but settings not saved” topic, but it did not helped.

By the way, the serttings are also not saved when I boot from NOR… is that normal?

Thanks, Gabor

“booted in emmc but settings not saved”

I believe I posted that topic. I remember I did some recovery & flash on the boot menu to solve the issue.

Do you have UART connection when doing trial flash?

Yes here:

So would be great if someone searches for problem first and if there is no matching thread add a new one.

As you can see in my post, I searched and found that topic, but that is different. I mentioned, that I tried it, and did not helped. Or I don’t understand your message, why do you wrote it? I should have posted in that topic? It was marked as solved, and different (only similar) issue. My problem is when booting from SD, not EMMC. I thought better to open a new one.

No, I don’t have UART connection. I flashed the SD card on a Windows PC and booted from that SD card. I did not flash on the Banana Pi anything to any intetrnal storage (NOR. NAND, EMMC).

Is that normal that the firmware which comes with the device on the NOR flash can’t save the settings? Is that normal that the firmware which is loaded from the SD card can’t save the settings?

Can’t save = saves to some temporar location, everything works until a reboot. After reboot restores the original state.

So I can edit it on the web UI, and check the config files with SCP… they are saved. I can edit the config on SSH connection, everything looks good… but after reboot it restores the state… So I gusess the files are loaded to a ram disk or similar. Or some file cache is not saved to the SD card for some reason.

Openwrt uses an overlay filesystem which is normally only in ram and gets lost on reboot. If you want parts of it it needs some space outside the overlay and configured on mount to use this as storage.

Nor (and maybe nand) are not that large to carry a full os and userdata. These spi-devices are for rescue purposes only…if you have a bootable os then you will have the maximum possible (linux kernel alone can be too much for nand…nor is even smaller).

Ok, then NOR flash can’t save the user data… I understand it. And what about the SD card?

What is the solution? Fhash to the EMMC? Will that preserve the settings after reboot?

Sd/emmc should save settings,but i guess bpi image is broken here. Please try vanilla openwrt build

I tried the bananapi_bpi-r3-sdcard.img image from the https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/ link… it preserves the changes on the SD card, so the HW is ok at least :slight_smile: However it has no web ui, no wifi… (I logged in with SSH and changed the password and created a file… after power off, it remembered the changes :))

So it is possible to preserve the changes when booting from SD, but there is no working image for that… :frowning:

So I think I have to flash the EMMC… I hope it will work.

The only thing that I do not undestand in the getting started document, why to do the flash in 2 steps… (flash SD, boot from SD, flash NAND, boot from NAND, flash EMMC)… since the NOR flash already has a working openwrt… so why not simply boot from NOR, which can accesss the EMMC and flahs the EMMC? (I haven’t tried it, but it seems much simple if the openwrt on the NOR flash can access the USB drive)

You have to install lucy for webfrontend.

Wifi should work (maybe you need to load modules for it.

My nor does not even have bootheaders…and if you flash nor or nand after sdboot does basicly not matter,you do not need openwrt or a linux kernel there to flash emmc…only external storage like usb (of if stored somewhere on the nor/nand) for loading bins to write (nor is too small for it)

Maybe you bought it before they started to deliver the router with a preloaded firmware. In this video (at 1:08) they mention that “Image file has been burned to NAND before delivery”… however it is burned to NOR, not NAND… and it seems he is booting from NOR, so it is only a mistake in the video, but the firmware is already flashed. At least in my device it was there.

I tried the bananapi_bpi-r3-sdcard.img image from the https://downloads.openwrt.org/snapshots/targets/mediatek/filogic

The stock image has issue i think, I never succeeded boot to EMMC after flash SD -> NAND -> EMMC using stock SD image, so I compiled & using SD image from compilation and did a Restore Boot loader, recovery, production image to them (NAND, EMMC) on boot menu (need UART connection).

It is highly recommended to get a UART adapter before you plan to flash firmware to any device, as some recovery procedure requires UART input, or you can observe the output in case something goes wrong.

Correct, it came with firmware installed on NAND on my BPI-R3.

It seem that it is flahsed to NOR and NAND, too… but in the video it mentions NAND, but the switches are all “Low”, which means the NOR flash.

I suggest you compile official Openwrt firmware (Snapshot) and copy to SD then boot from SD, it will be a lot easier than Sinovoip’s method, you can flash NAND, NOR, SD, EMMC right on the boot menu. see the 7,8 menu item.

Openwrt snapshot works wonderfully with BPI-R3, wireless AC,AX performance is amazing.


Ok, I buy an UART cable and will do that. Is it possible to build openwrt on windows? Is it easy?

Haven’t tried that in Windows linux subsystem, a real Linux is so easy to setup nowadays, almost plug & play with all the hardware detected & installed properly.

Forget about Windows, you are already at the front door of Linux (openwrt), so why not step in?

I also tried WSL to call the “wipefs”, but then give up… So booted an Ubuntu from usb drive. I’m a .NET developer, mostly working on a desktop (WPF) project, so I need Windows for that… maybe I’ll install it on a 2nd laptop.

Add a SSD/resize partition… make a dual boot.