BPI-R2 AP Mode Setup on New Ubuntu Image

Hi everyone.

I have downloaded the last ubuntu image of BPI-R2 from this link, BPI-R2 new image : ubuntu 16.04 V1.2.1 BT and WIFI AP mode are working fine 2017-11-27.

According to new features, I can use AP mode So, I want to use the R2 as Access Point and tried to create hotspot on Ubuntu. But, I couldn’t., I have taken "is not available " error.

Please Can you give me steps which are show how to create a hotspot on BPI-R2 lastest ubuntu image.

Thanks for helping.

Sorry I got my answer from

2.4Ghz and 5.6Ghz Wifi Working fine


Remove pkg wpasupplicant(apt-get remove wpa_supplicant) if you’re using Ubuntu 16.04 image

Comment out echo 1 > ${{WIFI_DEV} in /etc/init.d/wifi_enable if you’re using Ubuntu 16.04 image


Run command “echo A >/dev/wmtWifi”

Run comand : hostapd -dd -C /etc/hostapd/hostapd.conf

Below is an example of hostapd.conf: hw_mode=g interface=ap0 driver=nl80211 channel=1 auth_algs=1 ssid=test

Also the patch @BitMaster provided is delivered to github. Thanks a lot, BitMaster. https://github.com/BPI-SINOVOIP/BPI-R2-bsp/commit/219be3221aadb2d316557df8064bb231ca46ed5123

Hello, Yusuf, you can create a hotspot on BPI-R2 follow FW‘s steps, here is the link: http://www.fw-web.de/dokuwiki/doku.php?id=en:bpi-r2:wlan#internal

1 Like


When I run the “wmt_loader” command, It gives these errors;

init combo device
Opened combo device
get device id : 30243
set device id : 30243
do module init: 30243
failed to init module 

What Should I do? Have you any Idea?

Hi Yusuf,

I think you can find answer from here:2.4Ghz and 5.6Ghz Wifi Working fine


1 Like