2.4Ghz and 5.6Ghz Wifi Working fine

1 adapter = 1 AP

You can also use pcie for a second card

I know some adapter witch support 5 Ap by Adapter

Hello Everyone. I have a bad English.

I have a bpi-r2 and I wang to use AP-mode. Recently , I very surprised that a new image is released.

I using 2017-11-28-ubuntu-16.04-mate-desktop-bpi-r2-sd-emmc.img.zip. on eMMC.

I do this step by step.

However ,I can’t find the ap0 interface.

I try to “wmt_loader” , but

I try to “stp_uart_launcher -p /etc/firmware &” , but

Can’t open device node(/dev/stpwmt) error:-1

Anyone can help me ? Thank a lot.

You must do it in right order

I read the page too. I sure I do it step by step. But this error still exists. The files ( cfg , firmware , bin ) in the system before I copy in.Should I rewrite them ?

you have to do this steps after a clean (re)boot. if something went wrong => reboot

“failed to init module” in first step can be currently ignored

if the files exist, you have not to replace them

Can you please share me the log(getting it by running dmesg)?

Thank a lot !

I have find my mistakes. “failed to init module” and “Can’t open device node(/dev/stpwmt) error:-1” should be ignore. When I ignore it , I can create my AccessPoint.

Hi hyh

Both drivers and tools for R2 onboard WIFI module are from Android system, and we don’t have time to remove unnecessary code so far. so maybe the driver is working fine but there is a few errors in log.

Thanks Gary

Is btif driver needed for wifi,too?

Googled around…it seems to be a kind of uart. Having actual Problems compiling it

Hi Frank

The BTIF driver is required if WIFI or BT want to be supported. I think there is no problem to compile it in both kernel 4.9 and 4.4.

Thanks Gary

R2 internal Wifi/BT (MT6625L) - Kernel 4.14.x/4.16 don’t understand the errormessage (wrong code in base linux code is implausibly). also the other with undefined param, wich i fixed it quick and dirty by defining it

@garywang can you try to close hostapd and restarting it? in my tests the ap does not came up (hostapd says it comes up, but its not visible on cellular)

user do some test for 2.4G & 5.8G,for reference only

5.8G test:

8G wireless test

2.4G test:

4G wireless test

Hi. I am using the Ubuntu 16.04 2017-11-28 image and facing the same problem like @hyh I am unable to connect wifi with my router even by using the steps from https://github.com/BPI-SINOVOIP/BPI-R2-bsp/tree/master/vendor/mediatek/connectivity

I can see that the wlan0 is up. But the wifi is always disconnected. Also tried this steps, https://github.com/BPI-SINOVOIP/BPI-R2-bsp/issues/1 But no success.

-TIA, Prakash.

do you want to use R2 as AP or as Client? @hyh tries AP-Mode, here you must “echo A” and use ap0-device for hostapd

Hi Frank. I am trying to use as client. I also tried “echo 1”. Still same issue. May I know what is the right steps to use it as client. The right top Network Manager on the desktop UI never shows the wifi devices near by R2 board.

Do you connect an antenna to R2 board?

@garywang Nop. I did not. Is it mandatory?.

without antenna you have very bad transmission quality…if your router does not stand next to your bpi or you have overlapping wlans connect or scanning may fail