BPI-R1:OpenWRT slow throughput WAN

I installed OpenWrt Chaos Calmer V1.2.2-stable r48870 on Banana Pi R1 default settings, everything seams to be fine except some kind of traffic limiting. I have 1Gbps line, connected directly to PC I can get about 800Mbps up/down speed, but when connecting to Banana Pi R1 download rate stucks in about 5Mbps (speedtest.net) downloading file from ovh.net is total disaster 150Kbps

Tried changing various settings (web interface), nothing helped, also tried to change patch cable and LAN port, same. I’m not network specialist, I can provide my network config or screens if required, but maybe this is something obvious in default configuration?

No problem in LAN. Speed is ~300Mbps. (Expected more from Gbps ports).

I’m not very good at linux so using only WEB interface (Powered by LuCI for-15.05 branch) and getting more and more disappointed.

Here is more details about system: Model Lamobo R1 Firmware Version OpenWrt Chaos Calmer V1.2.2-stable r48870 / LuCI for-15.05 branch (git-16.093.27241-7b0ce5c) Kernel Version 4.1.20

Some examples

ping -s 1000 proof.ovh.net (10 mins. no packet loss) 1008 bytes from proof.ovh.net ( icmp_seq=49 ttl=55 time=45.0 ms 1008 bytes from proof.ovh.net ( icmp_seq=50 ttl=55 time=45.0 ms 1008 bytes from proof.ovh.net ( icmp_seq=51 ttl=55 time=44.8 ms 1008 bytes from proof.ovh.net ( icmp_seq=52 ttl=55 time=44.9 ms

ifconfig, nothing special here too…

eth0      Link encap:Ethernet  HWaddr 08:00:27:00:2A:09
          inet addr:  Bcast:  Mask:
          inet6 addr: fd2c:690b:b618:0:a00:27ff:fe00:2a09/64 Scope:Global
          inet6 addr: fe80::a00:27ff:fe00:2a09/64 Scope:Link
          RX packets:68364404 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41029140 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:86504527951 (80.5 GiB)  TX bytes:25167662987 (23.4 GiB)

And wget

[root@serv]# wget http://ovh.net/files/100Mb.dat -O /dev/null
--2016-08-23 17:43:44--  http://ovh.net/files/100Mb.dat
Resolving ovh.net...
Connecting to ovh.net||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 12500000 (12M) [application/octet-stream]
Saving to: “/dev/null”

24% [==================>                                                              ] 3,065,070    186K/s  eta 53s