BPI-M64 new image:ubuntu-16.04.1-mate-desktop-preview3-bpi-m64-sd-emmc.img 2017-02-16


  1. based on ubuntu 16.04.2 LTS LXDE 64bit desktop
  2. BPI-M64 kernel 3.10
  3. username & password: pi/bananapi , root/bananapi
  4. support HDMI 1080P & 480P & 720P (default)
  5. support GMAC
  6. support WIFI
  7. support BT (with bluetoothctl can setup)
  8. support EMMC (support boot from eMMC)
  9. support battery
  10. support IR (getevent can test)
  11. support power key (getevent can test)
  12. support OTG
  13. support CAMERA ov5640 (guvcview v2.0.3 and ffmpeg-3.2.1 support video H.264 hw encode)
  14. support bpi-copy to write SD/eMMC with img.zip file

Google Drive:

baidu cloud:

MD5: 1fa86d6a4c349c51e6bf970918ebf73a

Google Drive do not work((((((((((((

fixed this issue ,please try again ,sorry .

This is not a ‘BPI-M64 kernel’ but longsleep’s for Pine64 in outdated version 3.10.102 without fix for Dirty COW. In 2017. Are you kidding?

Also it seems you simply used all the work done by github user ‘avafinger’ without crediting him a single time: https://github.com/BPI-SINOVOIP/BPI-files/commits/master

When I boot this with my brand new m64, the red LED comes on for 11 seconds, goes off for 1 sec, and then the process keeps repeating. HDMI display shows the screen change to a black background with some horizontal rain like white lines for a split second before it goes dark and the output signal goes off. I tried 2 SD cards, and tried burning via both OSX and Windows but have no luck. Does this really work?

I checked the MD5, it is all good. I use a genuine Apple iPad charger as well as a third party charger with no luck. I also tried booting without any USB and HDMI and network to reduce power consumption but it is still the same. 11 seconds red LED, followed by a blip, then another 11 seconds red LED, another blip, …

I tried burning the full Raspbian image and that boots up fine though I see there is no WiFi support, eth0 has a 169.x.x.x address and I haven’t bothered further because I need WiFi support.

I’m about to try Avafinger’s stuff but do you guys Bpi have a simple Linux image I can use?


Same thing here.

I successfully managed to have Android work using PhoenixCard burning software (http://www.cnx-software.com/2015/01/06/easily-create-an-androidlinux-bootable-sd-card-for-allwinner-a80-devices-with-phoenixcard-tool/). However, I cannot make ubuntu work, nor Raspbian Lite. I also tried Avafinger job, but it didn’t worked as well.

I’m going to try Raspbian full and hope this will work, as I purchased a Banana pi to make it work on Linux.

I purchased a UART USB module to try debugging the ubuntu image, I hope I’ll see something meaningfull.

Do someone know a link to a working Linux image?

I finally managed to have Raspbian Lite work (maybe I did not correctly burned my SD card the first time). However, the image don’t work well:

  • WiFI is not working
  • GbE is not working. You need to change to 100Mb Full duplex manually to have network working correctly. As ethtool is not present, I forced the network port on switch side to be 100Mb and the banana pi adapted itself. However, I just saw that mii-tool might be present, so you could change to 100Mb by using mii-tool (https://wiki.debian.org/NetworkConfiguration#Setting_the_speed_and_duplex)
  • EMMC storage is not working

I’ll try again Avafinger image (https://github.com/avafinger/bpi-m64-firmware) as they claim that everything is working out of the box. But the burning method is unusual…

Also, a further step would be to have a mainline kernel working (version > 4.X.X), but it seems nobody managed to provide working images.

After a 2nd attempt, Avafinger image is working for me. I changed the power supply to use the DC input port instead of USB OTG and I think this made the difference.

GbE is working. Wireless seems to work (at least interface wlan0 is present). EMMC is working. So it’s all good for me.

Kernel is 3.10.102, far from the mainline, but apparently some improvement will be performed in 4.11 that will soon be released.

Google Drive do not work