BPI-M64 Android 6.0.1 source code

#BPI-M64 Android 6.0.1 source code

google driver link:


thank taili share this code.

Android compiler configuration file.txt


How about the linux kernel ? I tried to compile linux kernel : according to README, but select linux as the platform. (BTW, the start num is 0 , not 1 as in README), but failed.

Using default config …

make: Entering directory ‘/data/zzbdev/BPI-A64-Android/lichee/buildroot’ make: *** No rule to make target ‘sun50i_defconfig’. Stop. make: Leaving directory ‘/data/zzbdev/BPI-A64-Android/lichee/buildroot’

The Armbian guys sum it up as follows: https://forum.armbian.com/index.php/topic/3169-request-for-banana-pi-m64/?p=22323

So this code is not from you but from someone called taili? Who is this person and how does he/she relate to your development efforts?

I have successfully built and booted this Android6 source on the M64. If you are familiar with Allwinner build procedures you will be able to build it. This is not a normal Linux distribution, it does not build like a normal Linux distribution. You have to use the Allwinner build procedures.

I’m going to put it up on gitlab in a form were developers can use it. I’ll include some instructions on how to build it. You probably want the userdebug build so that you’ll get a serial console.

1 Like

Android compiler configuration file.txt


we just share a link to you ,and it work fine on BPI-M64, all driver working fine .:sweat_smile:

do you know where is Android 6 source codes? I can’t use their links

Hello, current Android 6.0.1 image for BPI-M64 is really nice. However, where is the source code? When I click to below link, it can’t open, gives 404 error !!


Where can I download BPI-M64 android 6.0.1 source?

HI: Please try it. https://drive.google.com/open?id=0B_YnvHgh2rwjdTRVRVFaSHd2cnc

Hi, thanks for the new link. I also find old sources, and tried to compile, but failed because of missing aarch64 toolchain in the old sources.

I find aarch64 toolchain from pine64 sources, copied into old sources, and compiled BPI-M64 Android 6.0.1 succesfully.

And then, I uploaded my sources to Gdrive: https://drive.google.com/open?id=0B_h6Fwa1Fb9rajBBN183dEwzMEE

Unfortunately, these sources does not include Google apps ( Such as Google play store ). I have integrated Opengapps into Nanopi android SDK before, and I think I can do it for BPI-M64 too. But why your default SDK doesn’t have it?

Can you please explain ?