BPI-M4/BPI-W2 Demo Image Release : Raspbian 9.8 stretch & AArch64 Linux Mate & AArch64 Linux Lite 2019-06-19

BPI-M4/BPI-W2 Demo Image Release : Raspbian 9.8 stretch & AArch64 Linux Mate & AArch Linux Lite 2019-06-19

AArch Linux Lite

Raspbian 9.8

image

1.About this release

  • This release is for banana pi M4 & W2 board, and it is based on Raspbian 9.8 & AArch64 Linux Mate & AArch Linux Lite Operation system with kernel 4.9.119.

2.Raspbian 9.8 stretch

3.AArch64 Linux Mate

4.AArch64 Linux Lite

5.FAQ

  • Issue: if HDMI doesn’t display, please try “ctrl + alt + F1” to change terminal then “ctrl + alt + F7” change to desktop display.

  • SW2: switch to 0,if insert SD, SD start;if doesn’t insert SD,EMMC start.

  • Startup Log:

1 Like
  • Issue: if HDMI doesn’t display, please try “ctrl + alt + F1” to change terminal then “ctrl + alt + F7” change to desktop display.
  • SW2: switch to 0,if insert SD, SD start;if doesn’t insert SD,EMMC start.

I flashed raspbian 9.8. boot from sd card. HDMI monitor is black keyboard not recognized. I cant try ctrl + alt + F1. I have edited config.txt with no resilts. My board not recognized monitor and keyboard. only mouse is lightning

never mind - sd-card was invalid

why raspbian has only 680MB Free? I set up 64MB RAM in settings.txt but it helps nothing. Where should i set up gpu memory

Hello,

I’m trying to make my bpi M4 working, but i have the black screen problem.

  • My SD card is 32g class 10,
  • My BPI is v1.0,
  • I tried every linux version (arch, arch lite, raspian, ubuntu…)

My steps :

  • I install the OS on the SD card from my laptop (debian 10) using the recommended bpi-tools
  • Then I disconnect it , and plug in to the BPI board, SW switch to 0 (SD boot), a usb keyboard, and a mouse
  • then I plug my power supply to the board (tried from my laptop usb port and my phone power-supply witch output 5V 3amp)

the results :

  • the two leds light on (activity and power), then the green one (act) start blinking like heartbeat, and the screen is detected and set black.
  • after that, nothing else happen.

the board seems to react to keystrokes : Ctrl+Alt+Suppr seems to make the board to reboot, the recommended Alt-F1 then Alt-F7 make the green led off, but not at first attempt.

Have any ideas?

It seems 2019-* images lightdm start fail, you can restart the lightdm service

$ sudo systemctl restart lightdm 

or try the latest ubuntu mate and raspbian stretch image. http://wiki.banana-pi.org/Banana_Pi_BPI-M4#Linux_Images