BPI-M3 using g_ether


I have a Banana Pi M3 and would like to use the USB-OTG Port for a additional network connection. In different How-to in the internet it seems to be pretty much simple: I just have to load the g_ether kernel module. But this module is not available in none of the images I tried out.

I tried to build my own kernel module but it seems not be that easy like the x86-architecture. I used different How-to but, most of them are old and are not referring to the M3. So none of them worked for me.

How can I build my own kernel Image with g_ether enable? Or is there a (non official) linux image available with this kernel module?

Thanks for your reply

  • Michael

Someone had a similar problem here : How to get the OTG working on linux for BPI-M3 maybe it can give you a hint.

Thank you for the link, this did not help me.

Running the command echo 2 > /sys/bus/platform/devices/sunxi_usb_udc/otg_role does not have any effect on my system. I don’t see the USB-device with lsusb, and I don’t see any corresponding message with dmesg.

Maybe this would change if I would be able to load the g_ether kernel module, but this don’t exists on my system …