[BPI-M3] New image:Berryboot and GPU (PowerVR SGX544) included in Ubuntu Mate 15.10

Download link:

Google Drive: https://drive.google.com/file/d/0B_YnvHgh2rwjNjNlcEpqQVNDLTg/view?usp=sharing

Baidu Cloud: http://pan.baidu.com/s/1dEe53PZ

MD5: 46f55765f7cd210678dd05cd6de08deb

Release Note:

  1. Aufs file system included in BPI-M3 kernel 3.4 (commit 2141b27fdbb5b3baff0bdff95aef3bbe8a7259ad)
  2. Berryboot supported
  3. Ubuntu Mate 15.10 included
  4. GMAC supported
  5. Camera ov8865 supported (mplayer tv://)
  6. Wifi supported (modprobe bcmdhd)
  7. Fatload script-bpi-m3.bin, kernel, and ramdisk supported
  8. Reboot issue fixed
  9. GPU PowerVR SGX544 supported (glmark2-es)

username & password: pi/bananapi , root/bananapi , bananapi/bananapi


1 Like

Hurray, thanks guys! :wink:

nice, thanks :sunglasses:

Thank you,

How can I flash it on emmc please ?

I can’t with dd, don’t boot

1/ You have to flash your sd with the image, 2/ You have to start, 3/ you have to install sshfs on your Bpi under a terminal as root with : apt-get install sshfs, 4/ you have to mount the *m3-sd-emmc.img on your Bpi from your main pc with starting the command : sshfs username@ipaddrofyourmainpc:/*m3-sd-emmc.img/mnt/ 5/ Once it is connected, just flash the internal EMMC with the normal flash instruction as dd if=/mnt/…/*m3-sd-emmc.img of=/dev/mmcblk1 bs=1M, 6/ Use the command : sync, 7/ Use the command : fusermount -u, 8/ Disconnect your Bpi or restart it by pressing on the reset button

That’s done guy!

When I did that (flash /dev/mmcblk1) the BPI M3 didn’t boot.

In my case Berryboot don’t work on emmc. Is it normal ?

jyc_emea, did you try this with this image ? Berryboot and GPU ?


I flashed this new image to SD card. I started U1510. Login first was successful, no user/psw asked. I tried to update the system, but during upgrading “There is not enough space…” error appears, so upgrading was not successful. (I used a 16 GB SD card). Thereafter i tried to playback some video files (xvid, 720p, 1080p) with VLC media player. The result is black screen in VLC. Thereafter i tried to playback a youtube video with Firefox. The result: playback does not start.

Thereafter i restarted the device, boot from U1510. Loging screen appears. i tried to login with " pi/bananapi , bananapi/bananapi, bpi/bananapi" users, but after login screen blinked and login screen appears again, so i could not to login. Login with root/bananapi was successful, but an error was displayed. “Error found when loading /root/-profile…”

I tried all with 2015-12-23-ubuntu-mate-15-10, but all issues occured again.

Can you help me?


Yes, I think when I DDed an Ubuntu image for another device, the software only partitioned it to a new KBs more than the Linux image. It was on a SD card so I took it out and GParted it to expand the volume. For Linux I am not sure how you would do it. Maybe resize it form Linux on MicroSD?

If I install this release with (dd if=… of=… bs=1M) on a empty card i can see the berryboot menu. If i select either u1510gpu or 2015-12-23-ubuntu… screen gets black and nothing happens. Did I miss something?

Screen gets black at first. Wait a minute and it will boot.

on both 2015-12-23… and u1510gpu ?

At least on the u1510.

I did not. But this a standard procedure under linux and unix

Don’t try to flash your microSD under linux with dd. You need to restore the image from the app Disks or better with Win32 Disk Imager at http://sourceforge.net/projects/win32diskimager/

After this, no problem to boot.

I am looking for a way to get this Image installed to the eMMC module. So far no luck. Any help would be welcome.

Youtube videos and video playback (xvid, 720p, 1080p) with VLC works well?

No, GPU ok but no HW video decoder

Same story, again and again. Does not work reliable. Please integrate GPU with regular image, don’t need fancy berryboot. Make ONE thing that works for everybody.

YouTube does not work. qq.

This is not working. The BPI will hold at the Splash Screen.