[BPI-M3] New image: Android 5.1 (Version:V3)

Android 5.1 2016-06-08 for BPI-M3

Release Note:

  1. LED Trigger default disable
  2. WIFI-Hotspot feature supported
  3. Muti-Resolution feature supported (HDMI version only)
  4. Static IP feature supported
  5. Android root feature supported


Google Drive:

Baidu Cloud: http://pan.baidu.com/s/1c2juiZY

MD5: 918b1d3707ce58cd203d0b392fa4cc8b


Google Drive:

Baidu Cloud: http://pan.baidu.com/s/1c1TfhIw

MD5: d5d8e33b05d1db502ad3d527e512ab27

Static IP feature supported

WIFI-Hotspot feature supported

Muti-Resolution feature supported


Downloaded the LCD V3 image and does not give the right signal in 480p for an Industrial LCD display even I select the 480p before, simply the screen format remains 720p and just re-shape the content to 480p. Debugged this info withan other display - Samsung full hd tv also not recognize as an 480p signal, stil remain 1280x720 on the samsung TV in the resolution info box.

Please try to give resolution for real 640x480 and 800x600 resolutions in order to being able used not only the latest gen. displays, thanks.

Thanks: Peter

HI: Muti-Resolution feature supported (HDMI version only).

Noop, if I select 1080p 60hz on my HDMI hp23 monitor, resolution don’t really stay at 1080 …but at 720p. And I use 3 different High quality HDMI cable…

Have a look at the last paragraph of the 1st post here: http://forum.armbian.com/index.php/topic/752-tutorial-h3disp-change-display-settings-on-h3-devices/

You could try to grab the correct fex file (this here for 1080p) and then clone their M3 github repo where this file is located to follow the linked procedure.

Allwinner’s BSP kernel for H3 and A83T is pretty similar so most of the stuff you find for H3 works fortunately also with A83T.

Yes I’ll try soon! Tanks!

tested the Android HDMI V3 image and the resolution issue still not resolved, because 480p setting gives 720x480 resolution instead of 640x480. So 4:3 aspect LCD resolutions missing, such as 640x480, 800x600.

A small Industrial LCD display works on 4:3 resolutions and not Wide Scren HD.

Can you point me to the instructions to build this Android image? I need to make a change to the connectivity manager to allow the use of wifi and ethernet at the same time.



LOL! The average BPi M3 customer is not able to check what he gets after purchase. That pretty much explains the whole mess.

I believe you are trying to say that they don’t release the Android source code? Is that correct?

Look through the forums. They do not even answer most basic user questions and obviously do not release Android source code (NDA lalalala), they do not even release all Linux stuff since their definition of ‘open source’ differs from the usual one (‘open source’ seems to be interpreted as ‘we can use everything but do not have to publish our changes’ – free beer not free speech)

I’m trying this Android image on the emmc, unfortunately I need an hdmi-dvi cable to use it. I’ve also installed Ubuntu Mate 16.04 on a microsd and managed to enable hdmi-dvi cable editing the file /media/pi/BPI-BOOT/bananapi/bpi-m3/linux/sys_config.fex and enabling hdmi_cts_compatibility = 1 in [hdmi_para] section and then: fex2bin /media/pi/BPI-BOOT/bananapi/bpi-m3/linux/sys_config.fex >/media/pi/BPI-BOOT/bananapi/bpi-m3/linux/script.bin

Is there any way to enable hdmi-dvi in this android image booting Ubuntu mate from micro-sd? When I boot from micro-sd I see those partition on /dev/mmcblk1 (I think they are the Android partitions on emmc since /dev/mmcblk0 seems to be the micro-sd):

Device          Boot   Start      End  Sectors  Size Id Type
/dev/mmcblk1p1  *    5218304 15335423 10117120  4.8G  b W95 FAT32
/dev/mmcblk1p2         73728   106495    32768   16M  6 FAT16
/dev/mmcblk1p3             1  5111808  5111808  2.4G  5 Extended
/dev/mmcblk1p5        106496   139263    32768   16M 83 Linux
/dev/mmcblk1p6        139264   172031    32768   16M 83 Linux
/dev/mmcblk1p7        172032  3317759  3145728  1.5G 83 Linux
/dev/mmcblk1p8       3317760  3350527    32768   16M 83 Linux
/dev/mmcblk1p9       3350528  3416063    65536   32M 83 Linux
/dev/mmcblk1p10      3416064  4988927  1572864  768M 83 Linux
/dev/mmcblk1p11      4988928  5021695    32768   16M 83 Linux
/dev/mmcblk1p12      5021696  5054463    32768   16M 83 Linux
/dev/mmcblk1p13      5054464  5218303   163840   80M 83 Linux

P.s.: the /dev/mmcblk1p7 partition contains a /vendor/modules/hdmi.ko which contains an hdmi_cts_compatibility string inside: root@bananapi:~# modinfo /media/pi/57f8f4bc-abf4-655f-bf67-946fc0f9f25b/vendor/modules/hdmi.ko filename: /media/pi/57f8f4bc-abf4-655f-bf67-946fc0f9f25b/vendor/modules/hdmi.ko alias: platform:hdmi license: GPL description: hdmi driver author: tyle srcversion: 4B9495B1103200669013890 depends: disp intree: Y vermagic: 3.4.39 SMP preempt mod_unload modversions ARMv7 p2v8

Where can get android5.1 sdk to rebuid my firmware ? thank you very much .

1 Like

I’ve successfully used Phoenix Card to put the HDMI version on my 8gb card. When I have it in my bpi pro nothing happens when it’s turned on. I even have the serial port connected to a terminal window… no output is seen. Even tried the 5.1.1 HDMI version with same problem. I’ve used the same sd card with Android 3.2 image and it boots fine. Any idea why 5.x images won’t boot?

Android 5 on M3 always freezes when HDD attached. Please help!

Nice work. CEC and PlayStore will be awesome!!

Installed this and for most part is running pretty good on the HDMI setup.

Netflix won’t work sadly. Black screen and audio only. :frowning:

For most part it runs pretty well on most other things. My son has been using it for a few hours today loading things on it and playing little games and what not.

You can try NOMOne Resolution Changer APK. It seems the output is actually 1080p, but the rendering upscales from a 720p canvas.

Anybody knows how i get xbox 360 controller run on Android ?