BPI-M3 continues to reboot

Installed jessie on SD card first time I booted it up worked fine for a couple hours the second time I used it the board it rebooted about ten times before it booted up. The third time no luck it just continues to reboot then powers off. I tried 2 other distros with the same result. Any ideas on what I am doing wrong I am fairly new to single board computers it was given to me as a christmas gift.

are you check your adapter, please use 5V2A adapter for BPI-M3,

Same Problem here. I use 5V4A for my BPI-M3.

Two things

  1. Read this, take your time - it helps

  2. when you fixed above, put a heat sink on the SoC it gets to HOT

Fix the problem download debian-8-jessie-mate I have shutdown and rebooted over 20 times without a hitch. I am currently running headless with only a network cable connected. VNC from my laptop. Can’t seam to get the wireless to work yet. I have tried again with raspbian -jessie and ubunta-mate 15.10 both continue to reboot.

With debian-8-jessie-mate the problems are gone, but the Image is too big for me. I need the rasbian. @sinovoip Is there a chance to update the raspbian-image to a stable one?

Have reboots on 5V2A and no WiFi (not fins any networks). Use Ugreen 5V 2,4A - all fine.