BPI-M3 Booting / EEMC / SD issues

Just got my BPI-M3 today… so far, huge PITA.

Got it to boot the Android image a few times after a painful time getting the EMMC flashed. Said all was good with the flash, but no video, until the 5th time it worked.

It ran for a little bit, but once I tried using the WIFI , it boots up to a certain spot and resets. Reflashed the Android image a few more times, but no go.

This the is the version with the mini USB port on it for power. Tried multiple cables and power bricks with it.

I would like to skip Android and try one of the Linux builds. I have a SD card flashed and ready to go. It actually booted up my Raspberry Pi2 for testing.

But I can’t seem to find anything about booting off SD… or erasing the EMMC or any of that stuff that seems to be common with the BPI-M3 currently. Lack of documents, and lack of being able to read Chinese on what little I can find.

So far, big waste of money and time.

Welcome to the club.

You should keep in mind that Raspberry Pi and Banana Pi use a different boot procedure. Therefore normal images suited for Raspberry Pi can’t boot on any of the Banana Pi models and in case there’s EMMC a fallback happens.

Try the most recent image from the download section here and see if that works. ‘Most recent’ because it might contain less bugs than the other OS images available (they are all buggy since the fixes they apply to their github repository can not be applied to the OS images they provide every few days).

According to this review http://forum.armbian.com/index.php/topic/474-quick-review-of-banana-pi-m3/ you might have to solder another DC-IN solution in case you still experience sudden resets.


When it would not boot of the SD card which was loaded with Banana Pi’s flavor of Raspian, just for kicks, I put the SD card into my Pi2 and it booted up to the point of the blue console screen configuration.

It just wouldn’t boot of the SD card… So I tried the EMMC deal for Android, and after a bunch of attempts, that did work. But I would still like to use the SD card and not Android.

If the SD image is “good”, does that mean it would boot off that first, before trying the EMMC ?

Is there anyway to clear the EMMC?

Is Android the only one that will go on the EMMC or can the rest do the same too? I tried their Raspian flavor, but the tool said it was bad.

I will try the DC-IN solution.

Based on the current situation with Linux images not being able to play video. I would discourage you from trying to burn the image on to eMMC. Android is barely working:p Also, I doubt Phoenix tools support linux images.

I think I will make a burning to eMMC video soon.

The description of BPI M3 on : bananapi.com

"What’s the BPi-M3

Banana PI BPI-M3 is the open source hardware platform :smile:, Banana PI BPI-M3 is an octa-core version of Banana Pi, it support WIFI+BT on board.

Banana Pi BPI-M3 series run Android, Debian linux, Ubuntu linux, Raspberry Pi image and others OS.and eMMC flash onboard." :smile:

Lie, lie, lie and lie :unamused:

It’s a false advertising. How sinovoip can explain that please ?

All Banana Pi models are TOTALLY incompatible. They only share the same name, form factor and GPIO pin layout (that might not work of course!) to fool customers.

It’s possible to create a dual boot image for one specific Banana Pi model to be useable together with Raspberry Pi but it’s not possible to create one OS image that would boot different boards called ‘Banana Pi’ (according to the Armbian founder it might be possible but only with a current version of the bootloader and not with the outdated software they use for their OS images)

So if you want to try out a specific Linux release for the M3 (as already said: they’re all buggy since they refuse to implement a software infrastructure to apply fixes to their OS images) then you would’ve to choose one image that was made for the M3.

Yes. And you can also flash any image to EMMC with dd. It will take just a few hours crawling through all forum posts since the instructions aren’t collected in a manual or wiki since they think random forum posts that will disappear automatically after some time are the same as appropriate product documentation. Good luck!

Wasn’t expecting it to be 100% compatible. Knew it was knock off basically with their own spin on things, which is fine… just stinks that their OS downloads are worthless… The image I got off their download page “Raspbian Jessie (Support emmc)” is one that wouldnt boot at all on the M3, but put in the pi2 … and it booted… I was figuring it was their “hacked” versions of Raspbian… if so, not hacked enough :smile:

So in my case, the one image that was verified good was the Android one… and thats why Pheniox tool was able to burn the eMMC while the other downloads are messed up for whatever reason to fail the tests before flashing the eMMC?

I was able to get it for a few seconds for my Windows machine to show what a think was the contents of the SD card and eMMC of the m3 but not 100% sure how that happened.

I still use the Linux image from here: http://linux-sunxi.org/Banana_Pi_M3#Images

I used dd in Linux to write it to SD card, booted from the card, put the image on an USB thumb drive and then used dd again to write it to EMMC directly on the M3.

and it worked?

If so please let me know… I am also having trouble with this…

Plus, I am not sure if there is a stable linux for M3 yet… This is driving me nuts… here…

Me myself am having trouble of seeing M3 on my computer with the right driver.

Solder on pins for a new power hook up.

Had a nice power supply setup that included an On/Off switch in the wire.

It powers on but just keeps rebooting…

Crummy video @ https://www.youtube.com/watch?v=uQY1cfTfkIs

Gonna play around with trying to get some other images onto the eMMC

After flashing the eMMC again and couple stuck booting sequences, it finally booted again to Android… But once again once I setup or attempt to setup WIFI it turns off and won’t boot again… have to repeat the whole process…

I can’t get it to boot of microSD at all… burned 6 different images to card… no video… no boot or anything.

If I reflash the eMMC with the Android image… it “works” again… until I do wifi and it craps out.

Mine boots on microSD fine and WiFi works perfectly. But I can’t write to eMMC. I don’t know if there is a step to wipe eMMC and just stick to the microSD.

May I ask what image is on your sd card? I dump the img file to them and try to boot but nothing seems to work. Only thing to ever work for me is the Android image but it quickly falls apart on me.

Have you had a look into the user manual how to successfully burn an image to EMMC (haven’t checked whether one is available/useable, still busy trying to get the M2 up and running)

The M3 Android Lollipop image found under the download page.

LMAO, I found this a few minutes ago: BPI-M3 user manual and hardware spec docment 2.0 version

It’s unbelievable someone would call such a compilation of nonsense ‘user manual’. There are so many things described plain wrong and so many informations missing. But at least it seems clear that Android and Linux images have to be burned to the M3 in different ways (why?!).

For me and my M2 this lack of support, software and documentation for both M2 and M3 are crucial. Will return my M2 tomorrow. 4 days wasted and nothing worked. The only exception being the Armbian image but there no HW acceleration for GPU and video seems to be possible for reasons unknown to me. I lost some time but no money thanks to the manufacturer being not able to provide correct product specifications. That makes it easy to return these defective boards with full refund :slight_smile:

i just got my M3 and had the exact same symtoms described here trying to boot Ubuntu Mate. i’m an embedded hardware/software engineer and have seen this many MANY times over the years with hardware that’s powered with micro usb ports. i do like #jdredd34’s advice for several reasons (unless you very little soldering experience).

get a quality usb cable and 5v usb plug adapter. Make sure it’s north of 2A especially if you have anything plugged in to the USB ports. toss the cable/plug that came with the board immediately. this fixed my issue immediately. technically you should only have the hdmi and vcc/usb plugged in on your first boot.

also make sure you’re using a quality sd card. that would have been the 2nd thing i checked. i believe at least a class 10 is recommended?

anyway this is literally my first post of this kind … ever. not looking for a debate or to hear sad stories. just wanted to try to help.

good luck!

Switched to Ubuntu Mate for now… doesn’t reboot… but its a bit on the slower side of things.

Wifi doesn’t want to work on it sadly it seems either… :frowning:

At least its in state of being somewhat useful…