BPI-M2P with Qualcom QCA7000

I am trying to get a BPI-M2P working with a Qualcom QCA7000 through SPI and am having a terrible time getting a kernel update.

We have code that works out of the box with any Raspberry Pi since the Rasbian builds have the QCA7k driver compiled in. I thought this would be the case with the BPI Rasbian build so we bought a dozen BPI-M2P boards since we could not get Raspberry Pi boards. When I tried I found the BPI Rasbian ignores the config.txt file so I could not enable the QCA7k DTO files.

So I downloaded the BPI-M2P-bsp and after a week of frustration I got it to compile with the QCA7k driver enabled. More frustration ensued as I tried to get the new image onto the BPI-M2P.

I finally think I got it on the SD correctly after realizing the build.sh install to SD script requires some things to be on the SD to begin with, but I still can’t figure out how to get it to see the QCA7000 part.

Is there anyone who has done this or can get me an image with the QCA7k driver ready to go, or are these BPI-M2P boards just expensive paper weights?