BPI -M2 Zero + Ultra Camera (OV5640) Modprobe: Fatal Module not found


I am complete noob, I installed: 2017-12-04-Armbian_5.36_Bananapim2zero_Ubuntu_xenial_next_4.14.3_desktop_preview_build_by_bpi.img as my flash.

I am trying to install (.ov5640) ultra camera onto my Banana pi BPI_M2 zero. I run the sudo modprobe ov5640 command and then get

modprobe: FATAL: Module ov5640 not found in directory /lib/modules/4.14.3-sunxi

please could someone tell me what is wrong

CSI / VFE is not ready on kernel 4.14.x, you need to use kernel 3.4.x

Thank you for your reply. I installed kernel 3.4.x as suggested.

I then ran following commands;

sudo modprobe ov5640 sudo modprobe sun8i_csi0

The first command ran with no error but second command gives error: fatal: module not found in /lib/3…4.x-sun8i

I have also tried sudo modprobe sun8i_csi and sudo modprobe sun8i_csi

First thing to check is if your Image has support for Camera (OV5640), that means the script.bin has OV5640 setup in it. I believe the MATE Image with the right bpi-tools will load OV5640/CSI at the boot time.

There is no sun8i_csi module and a load of the following modules would suffice to have camera working IF script.bin has ov5640 configuration:


You can check that after loading the two modules:

dmesg|grep ov
dmesg|grep OV
dmesg|grep VFE

if you don’t see error then you have success and can use your camera

BPI-M2 ZERO - CSI camera

$ dmesg | grep OV [ 9.147594] [OV5640@lex]init_sensor - frame_rate: 0, max_win_size: 11 [ 9.252262] [OV5640@lex]CSI_SUBDEV_PWR_ON! [ 9.331910] [OV5640@lex]sensor_init 0x0 [ 9.380640] [OV5640@lex]CSI_SUBDEV_PWR_OFF!

Very nice!

Do you plan to make you hardware extension available? If you do, please, reverse the reversed CSI pin at the sensor end and we can have a professional solution (more camera lens) and by the photos seems you plan night vision?