BPI-M2 Zero Packet loss

Hi everyone,

currently I have Ubuntu Server installed to use my BPI with Pi-Hole. Sometimes DNS queries are not answered until I refresh the website (for several times). I connected to the BPI via SSH, did a some ping-tests and the result was a huge packet loss (sometimes as high as 50%) - screenshot attached.

How I set everything up: The BPI is powered up with a 2.5A/5V power supply connected to the 5V/GND GPIO-pins. As I read in the wiki, Ethernet connection can be realized trough the 4 pins between the 2 micro-USB sockets. So I soldered pins on it and crimped an ethernet-cable with 4 plugs to not have to solder the ethernet-cable directly to the board. I’ve put a small heatsink on the CPU because temperatures without were too high (and I wanted to install it in a box without extra ventilation).

During the setup of Pi-hole I decided to completely reinstall everything (I had strange IP-issues) and it seems to me that it startet loosing packets since then (but I’m not 100% sure). Ping was loosing packets with the ISO’s Version of Ubuntu Server’s packets and the latest Version available.

I already tried to renew the connectors on the ethernet-cable, also checked the soldering, resistance through the cable and the temperature - everything seems to be ok.

Hopefully someone has an idea.


Does no one have any Idea?

I also tried to ping some internal IPs from the BPI and vice versa, this generated about 17% packet loss in both directions.

Compared to what?

For someone to try to help you you need to:

  • Provide dmesg output during boot and after you start having lost packages,
  • Provide Temperature values you have measured,
  • Router info, network info.
  • Cpu Load info, etc, etc…

Without information, it is just a guess, and my guess is you have issues with Temperature. Running higher than 75C will possibly affect other components.

And please, don’t put screenshots, attach the output files.

1 Like