BPI-M2 Zero not booting

Hi,

I’ve bought two BPI M2 Zeroes after learning my Raspberry Pi Zero just did not have enough processing power.

After struggling for a week or so getting them to boot I made this post.

I have these parts;

  • One BPI M2 Zero with soldered 5v pins, and serial pins
  • One BPI M2 Zero fresh out of box
  • An unbranded bad SD card
  • A Sandisk Ultra Class 10 16GB SD card
  • A Sandisk Extreme A1 32GB SD card
  • USB power supply 5v/2A from lab setup
  • 5v/10A PSU connectable to 5v pins
  • Both a Windows and Linux environment
  • USB UART controller
  • I even went and bought a “proven” SD card reader
  • Raspbian images, Armbian images, BPI images, many versions.
  • Images burnt with Etcher and dd

It seems that no matter what I configure in whatever way I just cannot get anything to boot. I feel like I must be missing something obvious as there are no common components and I seem to not have gotten into any of the common pitfalls I read about.

In any setup the onboard LED flashes red in a short-long-short-long(…) pattern. There is no HDMI output and I can’t read anything via serial on any tested boudrate.

Does anyone have some pointers or tips for me?

Thank you in advance.

Only connected 3pin uart debug port, 5V/2A adaptor to DC interface, still get nothing output from debug port? even garbled?

Did you see the red led on for a while then flashed like a heartbeat, then long on, then heartbeat…?

neither of the two boards not work?

Hi August,

Admittedly I’ve not tested the USB adapter previously so I cannot vouch for it’s operational status. Just a simple screen /dev/ttyUSB0 115200 results in an infinitely waiting terminal. Testing other baud rates from 9600 and up does the same. The red LED indeed starts by being on for a while, before going to the heartbeat pattern. I’ve waited a bit but it seems to continue the heartbeat indefinitely.

This is on both boards. On one I’ve not soldered the debug port as I wanted to keep it as-is to make sure I didn’t accidentally break both during soldering.

I’ve read through some reviews on aliexpress and banggood in the mean time and tried some of the comments and suggestions (mostly related to PSU or image) but have not yet gotten anything to work.

“The red LED indeed starts by being on for a while, before going to the heartbeat”, that means system bootup, at least kernel bootup correctly. continue the heartbeat indefinitely, almost the system bootup completely.

If 3 pin uart header soldered by yourself, please confirm it was correct, or you can flash the latest ubuntu mate or other latest desktop image, connect the hdmi and then power on the board to check the display output.

http://wiki.banana-pi.org/Banana_Pi_BPI-M2_ZERO#Linux

Hey,

I do this as a hobby and sadly enough I did not have time to test up until now.

I’ve gotten the MATE image from the page you linked, etched it using etcher, slapped it in both of the boards, and both have no hdmi output and loop the heartbeat.

One of the boards I’ve not soldered anything on.

The board I did solder on seems okay but remains silent on the serial port.

How likely is it I received two DOA boards? It seems unlikely but I’m unfamiliar with BPI’s reliability.

as i said before, red led heartbeat blinking means kernel bootup at least, so if you soldered the uart pin correctly and uart cable(3.3V io) correctly, then debug message will certainly be printed, so confirm uart pin, uart cable or PC communication.

about the no hdmi output issue, what type hdmi monitor used? default image output is standart hdmi 720p.

Hey, sorry about the long silence. Been a busy few months.

I wish I knew what happened but as I sat down to gather some more information it just… worked? I’ve since then installed Armbian without any issues either and tested all functions so far.

End goal is to have a video stream so next step is purchasing an appropriate camera module.

Thank you for your input so far and sorry for not being able to tell you what the issue was :slight_smile: