BPI-M2 Zero Not booting/No display


I am new to the Banana Pi community, and am having trouble with my M2Zero. I have downloaded the latest Ubuntu and Rasbian images and used Win32Disk imager to put th eOS on an SD. When i put the SD in the Pi the LED comes on and even begins to flash but i get no display via the HDMI. This is the same process i follow to have a similar Raspberry Zero and it works every time.

I have 2 BPis and the issue is the same so it seems to be something im doing wrong or something im not setting for the HDMI to work, any help would be greatly appreciated.



Thanx Igor,

Do i need to download the whole directory? Or just individual parts of it? Sorry its my first time using non rasbian software…

Check this: https://docs.armbian.com/User-Guide_Getting-Started/

Make sure that you are using a BPi image, standard Pi images wont work as the hardware is very different. Download an M2 Zero image from bannapi.

Hey there lol.

You’re going to want to download your preferred distro as a compressed image file (img.xz) either directly or via torrent from the repository Igor posted and flash it with Etcher to your SD card.

But I’m guessing you’ve done that…

Perhaps the board is trying to boot from eMMC? There are images on this forum specifically to get the board to boot with SD card (-: (but also reports of Armbian not liking HDMI)

You may also want to compile U-Boot; those armbian images do not include a boot sector going off the readmes

Official Armbian images surely includes boot loader … only in case there was some fatal failure in the build process. Very small % but possible. This particular board is not in the auto test rig, but other, similar ones are and they work fine. Since I don’t have this board, I can’t test and confirm that images are alright.


Thanx so much for the info. I had tried using BPi images of Raspbian, Ubuntu and Armbian without success across 3 different SD cards that all worked with RPi boards.

After reading the Armbian guide i upgraded all my SD cards and found that all the images i had downloaded work and the M2Z is working exceptionally well.


1 Like

Somehow, it appeared that, although initially I encountered the same problem, the reason was in my display’ hdmi incompatibility with BPI-M2 Zero. I found that booting process was pretty fine, when attached UART Terminal RXTX to PC through UART-TO-USB adapter. Then, after a few tries, I’ve found working display.