BPI-M2 Zero no WiFi

I have tried to get Wifi up and running on my bpi-m2 zero with 5 different images resulting in the same. I have tried running it with nmtui, nmcli, wpa_supplicant, iwlist wlan0 scan and iw dev wlan0 scan. Rfkill doesn’t return that the device is soft/hard locked and ip link gives the following:

wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT mode DORMANT group default qlen 1000
    link/ether d4:12:43:7a:0b:a2 brd ff:ff:ff:ff:ff:ff

I have tried creating a custom wpa_supplicant.conf, killed networkmanager and disabled all display managers, preventing it from starting any applets that are supposed to control the wifi controller as I want to run this headless. I’m clueless on what I can try next so I’d appreciate any help.

Try the latest m2 zero image 2020-04-28-*.img.zip

https://www.armbian.com/bananapi-m2-zero/ should also work just fine.

Thanks for your reply @igorpec and @August. I have already tried those images (both focal and buster for armbian) with the same result. I noticed when I armbian-config -> Network -> Hotspot, then the hotspot actually showed up, so I believe there’s something I’m missing but I don’t know just what yet.

Just a check: is an external antenna plugged in to your Banana Pi M2 Zero?

I thought my M2 Zero was unreliable because “it kept crashing” but SSH was dropping because the WiFi connection was weak. I did not know that unlike the Raspberry Pi Zero W, the M2 Zero requires an antenna. Antenna fixed my issue.

Hi @Colin_Ng,

I don’t have an external antenna. Did you buy or create one? As mentioned before, the odd thing is that the hotspot mode works and I can see the network showing up. It’s just not willing to find and connect to any network.

If the Banana Pi Zero cannot join an existing WiFi network, it might be the signal strength. You can test if the problem is signal strength by moving the zero to within 1m of the WiFi access point.

If you need an antenna, you can go with anything that uses an IPX connector.

I used a PCB antenna that came from another kit, the MAIX Sipeed

The web page doesn’t show the antenna, but it looks similar to:

There are also “rubber duck” antennas and other types too. I suppose if you had a dead PC laptop you could harvest one of its antennas too.

Thanks for the information. I couldn’t test this as my board’s FTDI capability suddenly was gone even though I tested it with different images, but that’s for an other topic. I wanted to try to create a hotspot on my phone whilst being next to the board to test.

Thanks for your help

For using softap, please search “modprobe bcmdhd” in the forum, and you will find some useful topics

I also had issues getting the BPi M2 Zero to connect to WiFi running raspbian (2020-04-28-raspbian-stretch-bpi-m2z-sd-emmc.img). If I did a wifi scan with “iwlist wlan0 scanning” it would return instantly with no results. If I however stopped wpa_supplicant with “service stop wpa_supplicant” and ran the iwlist again, I would get results with decent signal strengths.

I googled around and found this: https://forum.armbian.com/topic/5610-wifi-on-bpi-m2-plus/

Did the steps there and was able to connect to my WiFi! The steps were:

  • Run "wpa_passphrase wifi_ssid passphrase > /etc/wpa_supplicant.conf
  • Add the following to /etc/network/interfaces:

allow-hotplug wlan0 auto wlan0 iface wlan0 inet dhcp wpa-conf /etc/wpa_supplicant.conf