BPI-M2 Zero new image: ubuntu-16.04-mate-desktop-preview-bpi-m2z-sd-emmc.img-2017-09-19


google drive:


baidu cloud:


BPI M2 Zero runs 8*8 RGB LED

BPI M2 Zero runs camera and glmark2 and SPI OLED

What were the GLMark2 scores on this? Is it emulating OpenGL or running proper OpenGLES?

Are there drivers available to access the GPU?

Still no response to what should be a simple question?

Oh come on now…seriously…if your are going to advertise that your boards have OpenGLES and can promote that you run a benchmark, you can respond to a very simple question about the GLMark2 scores.

This really is not acceptable.

Still no response.


Glmark2-es2 use the openGLES score about 100

thank you So from that can we assume it has OpenGLES2 drivers?

Now that I have a board, and managed to install the same version of Ubuntu ran my own version of GLmark2-es2

got a score of 52 and 53 on 2nd try…

There is an explanation for such a slow score, depending on Desktop Window Manager you chose you get different score. Lighter Desktop environment which uses a different window compositor such as LXDE you get almost twice this score. For instance if you run es2gears on MATE you get ~170 and if you run on LXDE you get ~300 with HDMI 1920x1080p, with some tweaks you can get more. You can get even higher score just using a simpler window manager but you lose the bells and whistles MATE offers.

hmmm well GLmark2-es2 isn’t the same system as gears, and even working on a non GUI system it still returns a score int he low 50’s.


I am not really into this 3D thing. I just follow what others have done before, sorry if I can’t help much in this regard.

It seems I just have had a better luck to build my own image and run in 1920x1080 res which is workable despite most users report issues with this resolution. Running with 1920x1080 generates lots of heat and I still have minor issues with my build like tty framebuffer login (the one you type when you are with ALT+F1) is displayed over the desktop area and they share same keyboard input. My build use kernel 3.4.x

If i can fix this i may share the image if you can live with a low score (maybe not as low as you have now so you can get some improvement), for now, it is just PoC.

Technically the H2+ can display 4K so FHD desktop should not be a problem… Maybe it is just the mali version in use, who knows. Perhaps you can try more recent mali: https://bootlin.com/blog/mali-opengl-support-on-allwinner-platforms-with-mainline-linux/ but with mainline kernel.

BUT if you share some 3D C source code and can compile and see if it works or how it works (speed) and if the build worth a try.

1 Like

I’ll make a comment just to help the fellow future users who end up in this thread trying to use this image.

The image from this thread was actually the ONLY image I manage to work in my Banana PI Zero .

The user is: pi The password is: bananapi

working image linux ubuntu mate banana pi zero bpi m2 root password

1 Like

This comment helped me. Ill contribute too and say I just got this image working. WiFi connects but chromium doesn’t find the connection. I haven’t spent any time checking it out yet.

I even formatted my micro SD card with DD on my normal desktop computer, but no card reader, so I inserted it into this old JVC camcorder and this method worked. Didn’t have to do antyhing weird at all, except that I mkfs.vat on /dev/sbd1 but then when I used DD command, it was… /dev/sbd. no numerical. even though fdisk reports only partition as /dev/sbd1/

Little details like that… are why I look in forums at all.